We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Empty TIF when convert PDF to TIF using Aspose.PDF 9.4.0.0

When I convert a PDF to TIF on a specific windows server 2003 I got a 0k TIF file.

I could not reproduce it in 2 other windows server 2003…

any idea ?

thx a lot

FileInfo srcFile = new FileInfo(pdfFileName);
//create PdfConverter object
PdfConverter pdfConverter = new PdfConverter();
//bind input pdf file
pdfConverter.BindPdf(srcFile.FullName);
Resolution asposeResolution = new Resolution(300);
//initialize the converting process
pdfConverter.DoConvert();
// pdfConverter.

            //create TiffSettings object and set ColorDepth
            TiffSettings tiffSettings = new TiffSettings();
            tiffSettings.Depth = Aspose.Pdf.Devices.ColorDepth.Default;
            //To avoid Out of memory
            tiffSettings.Compression = CompressionType.LZW;

            //save pdf as tiff image
            try
            {
                //Export an EML file
                if (!Directory.Exists("Convert")) Directory.CreateDirectory("Convert");
                //  pdfConverter.SaveAsTIFF(fileTifTmp2, tiffSettings, new WinAPIIndexBitmapConverter());
                pdfConverter.SaveAsTIFF(GetTIFFileName(pdfFileName), tiffSettings);
            }
            catch (Exception ex)
            {

                throw new Exception("Error when converting PDF to TIF color - " + ex.Message, ex);
            }
            pdfConverter.Close();
            pdfConverter.Dispose();

Hi there,


Thanks for your inquiry. I am afraid it is difficult to suggest anything without replicating the issue at our end. Please share your sample PDF document, we will test the scenario and will provide you more information accordingly.

We are sorry for the inconvenience caused.

Best Regards,

hi,

thx for reply. It doesn’t works with any PDF on this server… I know it’s can difficult to understand why if we can’t reproduce and you can’t access to this server. I already spent too much time on this one. As it was a qualification server, we tested on the production server and it was working…
So only this specific server with 2003 32 bit as this issue.

I tried to build a simple exe to test with only the code I posted earlier.

I tried to use Aspose.PDF build for every kind of .NET.

I tried to set target build to x86 and Any CPU. Still the same…

I don’t understand which extra component from the OS, Aspose need to work.

Maybe you already faced to that issue and could provide me some direction to surch on the system to solve this issue.

Thanks a lot
Alain

Hi Alain,


Thanks for your feedback. I am afraid we have not faced any such issue in past. However I will discuss the issue with development team and will share the update with you. Meanwhile, can you please confirm you are facing issue only with TIFF image or other image formats as well. Please convert PDF pages to PNG and share the results.

Best Regards,