Free Support Forum - aspose.com

\endash vs. \u8211

Hello,


when I open/save a MS Word generated rtf file containing \endash characters Aspose.Words converts them to \u8211. Is there a way to preserve the \endash-Tags?

Best regards
Klemens Schrage

Hi Klemens,


Thanks for your inquiry. Could you please attach your input Word document here for testing? I will investigate the issue on my side and provide you more information.

Please see the attached files.

Hi Klemens,


Thanks for sharing the documents. I have managed to reproduce the same issue at my side. I have logged this issue as WORDSNET-7977 in our issue tracking system. I have linked this forum thread to the same issue and you will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

Hi Klemens,


Thanks for your patience. It is just to update you that our development team has completed the work on the issue (WORDSNET-7977) and has come to a conclusion that this issue and the undesired behaviour you’re observing is actually not a bug in Aspose.Words. It’s Aspose.Words feature to treat this special character as a symbol. \u8211 is a Unicode character for \endash.
http://www.fileformat.info/info/unicode/char/2013/index.htm

Hi,


I know that both variants are equivalent. However my question was if I can disable this conversion via a special flag or something like that.

Best regards
Klemens Schrage

Hi Klemens,


Thanks for your inquiry. Unfortunately, there is no property/method to disable such special characters like (\endash) while conversion of RTF. However, I have shared your request with develompment team. They will analyse this issue and will share their findings about this issue. As soon as any information is shared by them, I will be more than happy to share that with you.

We apologize for your inconvenience.