We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error : Attempted to read or write protected memory when sending a request meeting with Aspose.NetWorks

Hi,

When trying to send a request meeting through Aspose.Network, I have in my integration environment (64 bits) the following error :

Notes : I also send mail through Aspose and it works great, only have this issue with request meeting.

Notes bis : It works great on dev station on 32 bits environnments

Could you provide any fix ? As I mentioned i'm now using 5.4.0.4 version, at first we used 5.1 version but the error is still the same.

My customer (Top 5 french companies) uses licenses for Aspose.Total and he plans to push the application to production at the end of the mounth. Fixing this issue is critical for the application success.

Attempted to read or write protected memory. This is often an indication that other memory is corrupt. at Aspose.Network.iCalendar.TimeZoneInfo.TryGetLocalizedNamesByRegistryKey(RegistryKey key, String& displayName, String& standardName, String& daylightName) at Aspose.Network.iCalendar.TimeZoneInfo.TryGetTimeZoneByRegistryKey(String id, TimeZoneInfo& value, Exception& e) at Aspose.Network.iCalendar.TimeZoneInfo.TryGetTimeZone(String id, Boolean dstDisabled, TimeZoneInfo& value, Exception& e) at Aspose.Network.iCalendar.TimeZoneInfo.GetLocalTimeZone() at Aspose.Network.iCalendar.TimeZoneInfo.get_Local() at Aspose.Network.Mail.Appointment.x2bb35897d41e4221(x178df0686591b1e1 x1306445c04667cc7, Int32 x2debfb396e7b8224) at Aspose.Network.Mail.Appointment.RequestApointment(Int32 sequenceId) at Aspose.Network.Mail.Appointment.RequestApointment() at

Environment detail :

Win2K3 64bits SP2

Aspose.Network 5.4.0.4

SharePoint 2007 SP2

Code :

public override void Send(SPWeb web)

{

System.Diagnostics.Debug.WriteLine("Class MeetingRequest - Method Send - Start");

//Retrieve SMTP

String smtpHost = Business.Common.ConfigurationManager.GetParameter(web, ConfigurationManager.ExchangeServer);

aspose.SmtpClient smtpC = new aspose.SmtpClient(smtpHost, 25);

aspose.MailMessage msg = new aspose.MailMessage();

//Sender address : Sharepoint

String spFrom = Business.Common.ConfigurationManager.GetParameter(web, ConfigurationManager.EmailFrom);

System.Diagnostics.Debug.WriteLine("Class MeetingRequest - Method Send - spFrom" + spFrom.ToString());

msg.From = new aspose.MailAddress(spFrom);

//Set the 'reply to' to the define user

if (string.IsNullOrEmpty(ReplyTo))

msg.ReplyTo = new aspose.MailAddress(spFrom);

else

msg.ReplyTo = new aspose.MailAddress(ReplyTo);

//Define the attendee of the message

foreach (String attendee in To)

{

if (!String.IsNullOrEmpty(attendee))

msg.To.Add(new aspose.MailAddress(attendee));

}

aspose.Appointment app = new aspose.Appointment(Location, StartDate, EndDate, msg.ReplyTo, msg.To);

msg.HtmlBody = "" + Body + "";

app.Description = msg.HtmlBody;

app.Summary = Subject;

msg.Subject = Subject.Replace("\r", "").Replace("\n", ""); ;

msg.AlternateViews.Add(app.RequestApointment());

smtpC.DeliveryMethod = aspose.SmtpDeliveryMethod.Network;

System.Diagnostics.Debug.WriteLine("Class MeetingRequest - Method Send - Before Send");

try

{

smtpC.Send(msg);

}

catch (Exception ex)

{

System.Diagnostics.Debug.WriteLine("Erreur : " + ex.ToString());

}

System.Diagnostics.Debug.WriteLine("Class MeetingRequest - Method Send - After Send");

Thanks !

Hugo PAIN

Hi,

For information, I tried with aspose.network 5.5 and had the same issue.

Hugo

Hi Hugo,


I have reproduced the error at my end and logged this bug in our system (ID: 19107). We will get back to you as soon as it gets fixed. Sorry for the inconvenience.

Hi,

Thanks for your quick answer. Do you have any date for the a fix ? Actually we plan to push to pre production the code at the end of the week, so I guess we will have to fall back on using webdav instead if you don’t have fix :frowning:

Hi,


We are working on this issue and will try our best to provide you the fix at/before end of this week.

Hi,

Would be really great ! I take that on my project plan as a “B Plan”.
Thanks again for your reactivity.

Regards,

Hugo PAIN

Hi Hugo,


Please find the attached hotfix v5.5.0.1. It should fix the bug with sending appointments on x64 systems.

Hi Saqib,

Thanks a lot for your reactivity ! Actually we had to fall back to webdav for our release and test as the timing was short but we kept the aspose source code and will update it for our next release next mounth.
I saw that you include client integration such as Outlook tracking in the 5.5 this is a great a feature that we will probably use.

I’ll keep you updated.

Hugo