We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

ERROR: Exception caught instantiating ASPPSX report server extension (SSRS)

Working to install and configure a new version of ASPOSE and we are getting the following error. We have run through all suggested fixes in another similar article with no luck. Therefore, PermissionSetName=“FullTrust” is set in our environment and we have run gacutil against the reporting services dll. Both with no luck. Anythink else we need to check?

extensionfactory!ReportServer_0-2!173cc!12/05/2019-15:07:47:: e ERROR: Exception caught instantiating ASPPSX report server extension: System.TypeLoadException: Could not load type ‘Microsoft.ReportingServices.ReportRendering.IRenderingExtension’ from assembly ‘Microsoft.ReportingServices.ProcessingCore, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91’.
at System.Reflection.Assembly._GetType(String name, Boolean throwOnError, Boolean ignoreCase)
at System.Reflection.Assembly.CreateInstance(String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
at Microsoft.ReportingServices.Diagnostics.ExtensionClassFactory.<>c__DisplayClass2.b__0()
at Microsoft.ReportingServices.Diagnostics.RevertImpersonationContext.<>c__DisplayClass1.b__0(Object state)
at System.Security.SecurityContext.runTryCode(Object userData)
at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
at System.Security.SecurityContext.Run(SecurityContext securityContext, ContextCallback callback, Object state)
at Microsoft.ReportingServices.Diagnostics.RevertImpersonationContext.Run(ContextBody callback)
at Microsoft.ReportingServices.Diagnostics.ExtensionClassFactory.CreateExtensionObject(Extension extConfig, Boolean typeOnly).

@hafleym

Unfortunately, your question is not clear enough therefore we request you please elaborate your inquiry further. Also, please supply input RDL/RDLC files along with data source here for testing. This will help us to understand your scenario, and we will be in a better position to address your concerns accordingly.

Working to install and configure Aspose.Slides.ReportingServices_19.10 in our SSRS instance (SQL Server 2016). We are gettign the following error. There is a similar post from a few years ago and we have run through all suggested fixes in another similar article with no luck. We have verified that PermissionSetName=“FullTrust” is set in our environment and we have run gacutil against the reporting services dll. Both with no luck. What else could be causing this error? Hopefully this is clearer.

extensionfactory!ReportServer_0-2!173cc!12/05/2019-15:07:47:: e ERROR: Exception caught instantiating ASPPSX report server extension: System.TypeLoadException: Could not load type ‘Microsoft.ReportingServices.ReportRendering.IRenderingExtension’ from assembly ‘Microsoft.ReportingServices.ProcessingCore, Version=12.0.0.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91’.
at System.Reflection.Assembly._GetType(String name, Boolean throwOnError, Boolean ignoreCase)
at System.Reflection.Assembly.CreateInstance(String typeName, Boolean ignoreCase, BindingFlags bindingAttr, Binder binder, Object[] args, CultureInfo culture, Object[] activationAttributes)
at Microsoft.ReportingServices.Diagnostics.ExtensionClassFactory.<>c__DisplayClass2.b__0()
at Microsoft.ReportingServices.Diagnostics.RevertImpersonationContext.<>c__DisplayClass1.b__0(Object state)
at System.Security.SecurityContext.runTryCode(Object userData)
at System.Runtime.CompilerServices.RuntimeHelpers.ExecuteCodeWithGuaranteedCleanup(TryCode code, CleanupCode backoutCode, Object userData)
at System.Security.SecurityContext.Run(SecurityContext securityContext, ContextCallback callback, Object state)
at Microsoft.ReportingServices.Diagnostics.RevertImpersonationContext.Run(ContextBody callback)
at Microsoft.ReportingServices.Diagnostics.ExtensionClassFactory.CreateExtensionObject(Extension extConfig, Boolean typeOnly).

@hafleym

Your query is related to Aspose.Slides. So, we are moving this thread to Aspose.Slides forum where you will be guided appropriately.

@hafleym,

I have observed the issue shared by you and request you to please try using latest Aspose.Slides for Reporting Services 19.11 on your end. In case the issue is still reproduced, please provide the Operating System details, SQL Server complete version details, complete stack trace reproducing the issue. I also suggest you to please consider installing Aspose.Slides on your end manually by following the guidelines shared over this documentation link.

Thank you. Installing 19.11 and copying the new version of Aspose.Slides.ReportingServices.dll from the Universal directory fixed our issue.

@hafleym,

Its good to know things are resolved on your end. Please feel free to share if you encounter any issue.