Free Support Forum - aspose.com

Error getting a Range's Bookmarks in 11.10 and 11.11 on Mono

I’m running Aspose.Words on a Linux box using Mono, and upon accessing the Bookmarks property of a Range object, I’m getting the following error in Aspose.Words versions 11.10 and 11.11. I was hoping to use 11.11 because of all the PDF fixes since I save DOCX and PDF versions. All prior versions function just fine. I’ll try to include applicable information below, but let me know what else you need.


Unhandled Exception: System.TypeInitializationException: An exception was thrown by the type initializer for x2892>
5550 at Aspose.Words.NodeCollection.xe88ab84767e8fb69 () [0x00000] in :0 %
5551 at Aspose.Words.NodeCollection…ctor (Aspose.Words.CompositeNode container, x28925c9b27b37a46.xdbbc00f1636b87bc >
5552 at Aspose.Words.NodeCollection…ctor (Aspose.Words.CompositeNode container, NodeType nodeType, Boolean isDeep) [>
5553 at Aspose.Words.CompositeNode.GetChildNodes (NodeType nodeType, Boolean isDeep) [0x00000] in :>
5554 at Aspose.Words.CompositeNode.get_ChildNodes () [0x00000] in :0 %
5555 at x28925c9b27b37a46.x2c229a2f278462bd…cctor () [0x00000] in :0 %
5556 — End of inner exception stack trace —%
5557 at Aspose.Words.Range.get_Bookmarks () [0x00000] in :0 %

Aspose 11.10 or 11.11 (11.5-11.9 run correctly)
Mono version 2.10.9
Gentoo - kernel 3.6.11

Hi Vince,


Thanks for your inquiry. Could you please attach your input Word document (.docx/.rtf files) along with the source code here for testing? I will investigate the issue on my side and provide you more information.

Best regards,

Actually, I cannot, all my work is proprietary and company owned. I can try and duplicate the problem in some sort of test case. I will post it when I can. If you could check for any changes in Range.get_Bookmarks between 11.9 and 11.10, that might explain something. Any other way we can figure this out?

Hi Vince,

Thanks for your inquiry. Unfortunately, it is difficult to say what the problem is without the document and code. I need this document and code to reproduce the problem on my side.
It is safe to attach files in the forum. If you attach your document here, only you and Aspose staff members can download it. Also, you can send the file to my e-mail as described here:
http://www.aspose.com/corporate/purchase/faqs/send-license-to-aspose-staff.aspx
You can also remove any sensitive information by replacing it with dummy data instead.
Best regards,