We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error in coverting excel to pdf

Hi,
I converted a date format cell to pdf in ubuntu system. The result is not the date value as expected, instead, it displays lots of '#'s, as attached file shows. It works fine in my Mac, but in ubuntu, error appears. How could I resolve this problem?

Hi,

Thanks for your posting and using Aspose.Cells.

Do you get #'s because the column width is lesser? Do they get removed when you increase the width of the column manually using Microsoft Excel.

If you are facing this problem, then please call

Worksheet.autoFitColumns();

method before saving to pdf and it should fix your issue. Let us know your feedback.

Hi,

Thank you for response. Increasing the width solves this problem. because it shows date value in english, but original file is in chinese format, after I change locale info of workbook setting, It works out.

Hi,

Thanks for sharing good news with us and using Aspose.Cells.

Did you try auto fit columns method, it should also fix your issue. We are glad to know that you were able to sort out this issue. Let us know if you encounter any other issue, we will be pleased to look into it and help you further.

Hi,

auto fix columns method is not suit for my program, but thanks a lot for helping!

Hi Lou,


Thank you for writing back.

Please note, in Excel when a numeric/date value doesn’t fit the cell width then it is displayed as a string of # characters so you have to increase the cell width (column width) to workaround this situation. You can either auto fit all columns or a particular one just before rendering the spreadsheet to PDF or image formats.

Please feel free to contact us back in case you have further questions for us.