We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error in Formula when I save as ODS

Hi,

I have included this simple formula in a cell:

cell.Formula=IF(A1=0,0,B1/A1)

When a I save the file as Excel works fine, but if I save the file as OpenOffice, the cell shows an error because the formula includes commas (,) instead of semi-colons (:wink:

Thanks in support…Antonio



Hi,

Well, I think this is the limitation of OpenOffice (ODS) format that requires only ‘;’ as parameter separator. You may confirm it by manually applying the formula in e.g OpenOffice.org suite and you will see that it only accepts ‘;’. When you give ‘,’, it will give your error.

Thank you.

Hi,

This limitation that you are talking about is similar in Excel (at least with my Excel version).

If I try to fix it providing to the Aspose Cell Formula property a formula with semi-colons, I get an exception.

So I believe that it is really a Aspose bug/restriction, because ASPOSE generates ODS files, if there is no formula on it.

Thanks in advance…Antonio

Hi,

I have logged your issue into our issue tracking system with an id: CELLSNET-20247. We will look into it and get back to you soon.

Thank you.

Hi,

Could you give us details, <!–[if gte mso 9]>
<w:WordDocument>
<w:View>Normal</w:View>
<w:Zoom>0</w:Zoom>
<w:TrackMoves/>
<w:TrackFormatting/>
<w:PunctuationKerning/>
<w:ValidateAgainstSchemas/>
<w:SaveIfXMLInvalid>false</w:SaveIfXMLInvalid>
<w:IgnoreMixedContent>false</w:IgnoreMixedContent>
<w:AlwaysShowPlaceholderText>false</w:AlwaysShowPlaceholderText>
<w:DoNotPromoteQF/>
<w:LidThemeOther>EN-US</w:LidThemeOther>
<w:LidThemeAsian>X-NONE</w:LidThemeAsian>
<w:LidThemeComplexScript>X-NONE</w:LidThemeComplexScript>
<w:Compatibility>
<w:BreakWrappedTables/>
<w:SnapToGridInCell/>
<w:WrapTextWithPunct/>
<w:UseAsianBreakRules/>
<w:DontGrowAutofit/>
<w:SplitPgBreakAndParaMark/>
<w:EnableOpenTypeKerning/>
<w:DontFlipMirrorIndents/>
<w:OverrideTableStyleHps/>
</w:Compatibility>
<w:DoNotOptimizeForBrowser/>
<m:mathPr>
<m:mathFont m:val=“Cambria Math”/>
<m:brkBin m:val=“before”/>
<m:brkBinSub m:val="–"/>
<m:smallFrac m:val=“off”/>
<m:dispDef/>
<m:lMargin m:val=“0”/>
<m:rMargin m:val=“0”/>
<m:defJc m:val=“centerGroup”/>
<m:wrapIndent m:val=“1440”/>
<m:intLim m:val=“subSup”/>
<m:naryLim m:val=“undOvr”/>
</m:mathPr></w:WordDocument>
<![endif]–><!–[if gte mso 10]>

/* Style Definitions */ table.MsoNormalTable {mso-style-name:"Table Normal"; mso-tstyle-rowband-size:0; mso-tstyle-colband-size:0; mso-style-noshow:yes; mso-style-priority:99; mso-style-parent:""; mso-padding-alt:0in 5.4pt 0in 5.4pt; mso-para-margin:0in; mso-para-margin-bottom:.0001pt; mso-pagination:widow-orphan; font-size:11.0pt; font-family:"Calibri","sans-serif"; mso-ascii-font-family:Calibri; mso-ascii-theme-font:minor-latin; mso-hansi-font-family:Calibri; mso-hansi-theme-font:minor-latin;}

<![endif]–><span style=“font-size: 11pt; font-family: “Calibri”,“sans-serif”;”>Which language settings you use in your machine?

Thank you.

Hera you have my configuration info:

O/S: Windows 7
NET Framework: 3.5
Regional Settings: Spanish (Spain)
Openoffice: 3.1.0

Hi,

We have fixed the issue, kindly try the attached version.

Thank you.

Hi,

I have tested and it works fine.

Thanks your support…Antonio

The issues you have found earlier (filed as 20247) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.