Free Support Forum - aspose.com

Error on install of new version

Cannot connect to Internet Information Services when it tries to start the IIS Metabase Transaction.

Error code was 2147221164

I have Win 7, 64 and have IIS installed. BUT, I shouldn't have to have IIS to use Aspose. I know parts may, but I don't use those parts.

Anyway, I thought you guys might want to know. I will try and figure out a fix to get around it.

Alan

Hi Alan,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for the details.

We will investigate your issue as per the system environment details provided by you to figure out the issue. We will get back to you soon. Your issue has been registered in our internal issue tracking system with issue id :CELLSNET-15839.

Thank You & Best Regards,

I think this is the same issue I reported in http://www.aspose.com/community/forums/permalink/230720/231826/showthread.aspx#231826. I'm also running Win7 64 bit, but do not have IIS installed.

Rick

Hi Rick,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

We will look into it and get back to you soon.

Thank You & Best Regards,

As a followup, tried to install on WinXP 32 bit. If I install from the new Aspose.Total (the latest with cells 9.0) I get an error saying "Failed to install Aspose.Cells. Continue with other components?". If I try to install it by just running the msi file, I get the same error reported earlier (Cannot connect to Internet Information Server).

I can install Aspose.Words with no problems on either OS (winXP 32 bit and Win7 64 bit). I do notice that the install screen for cells is different than words (or even the older version of cells).

Rick

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for the detailed feedback.

We are looking into the msi installer issue and will update you as soon as we figure it out. Meanwhile, please download and try the latest version of Aspose.Cells (dll only) from the following location.

http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry232019.aspx

Thank You & Best Regards,

Hi Rick,

Please re-download the installer Aspose.Cells for .NET v4.9.0: http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry231670.aspx
and try installing the product again. We have fixed a possible installation issue for the machines having no IIS installed.

Please do let us know if you still find any installation issue now.

Thank you.

Still not working. Image attached of the error.

Hi,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for the feedback.

We will further look into your issue and get back to you soon.

Thank You & Best Regards,

I tried to install the latest version and I’m also receiving the same error.

Hi,

I think you might be using Win7 on 64-bit without having IIS installed on the machine. We are investigating the issue simulating the environment, the installer works fine on other machine / environments though. We will fix the issue in the next week.

In the mean time please use Aspose.Cells for .NET v4.9.0 (DLLs only) version from the site:
http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry232019.aspx

Thank you.

Just keep in mind, though, that I absolutely have IIS installed and running. I just checked it.

Hi,

Yes, we are also aware of IIS versions clash for the installer which consequently denies installing. We will fix the issue early in the next week.

Thank you.

Hi,

Could you re-download and install the installer for Aspose.Cells for .NET v4.9.0 on your environments now: http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/entry231670.aspx

(Note: please uninstall previous Aspose.Cells version if you have on your Win7 64bit machine).

Kindly do let us know if the installer works fine now.

Thank you.

That did it.

Thanks.

Alan