We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error uploading Word 2003

Hello.

One of our clients tried to upload 2003 word doc to our site and got this error message;


mscorlib error ‘80004003’
Key cannot be null. Parameter name: key
/_server_common/hirediversity/resume/alter/save.asp, line 98


The Line 98 reads;

doc.Save_4 mydir & Filename & ".txt", 4

So I saved the doc in Word97 format and uploaded - succeeded.

But when I tried to upload the Word 03 file - got same error.

Can anybody help me on this, please!!

Hi

Thanks for your request. Could you please attach your document for testing? I will try to reproduce the issue and provide you more information.

Best regards.

Ok, here is the file.

Thanks for your help!

Hi

Thanks for your inquiry. I can’t reproduce this issue on my side. I use the latest version of Aspose.Words for testing. Please try using Aspose.Words 5.2.1. You can download it from here:

If this does not help then provide me code that allows to reproduce this issue.

Best regards.

I have installed the latest Aspose.Word 5.2.2

And I tired to upload the resume and got this error;

error '8000ffff'
/_server_common/hirediversity/resume/alter/save.asp, line 87

And line 87 is;

Set license = CreateObject("Aspose.Words.License")

We are using Classic ASP.

Am I missing some steps? I just installed the latest one. Do I need to reboot the server?

Addition;

I kept installing different version and found the one which works - 5.1.0

I tried; 5.2.2, 5.2.1 - those didn’t work

What is the difference between those versions? Why some work and some don’t?

Hi

Thank you for additional information. There are no differences between these versions except fixes done in the newest versions.

I think there is some problem in your environment because I can’t reproduce this issue at all.

Best regards.

5.1.0 worked only one day, and next day it returned the error;

error '8000ffff'
/_server_common/hirediversity/resume/alter/save.asp, line 87

I don’t understand all this.

Many versions of Aspose.Word don’t work for us and few works but it worked for only one day?

You said there might be our side of problem, but how can I find what’s wrong with us?

Is there anything to do with Classic ASP? since we are using classic asp.

Hi

Thanks for your inquiry. Please see the following links


Maybe this information could help you to solve this problem.

Best regards.