Free Support Forum - aspose.com

Error when exporting a report

Hi,

I’m opening this post 'cause I’ve got a problem compiling a report using aspose.words for jasperreports: in the attached report, if I remove the footer band from the main report (s_99_2_2.jrxml) I get this error when trying to print.

type

Exception report

message

description The
server encountered an internal error () that prevented it from
fulfilling this request.

exception

javax.servlet.ServletException
ReportRumore.processRequest(ReportRumore.java:108)
ReportRumore.doPost(ReportRumore.java:172)
javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

root cause

javax.servlet.ServletException
ReportRumore.CompileReport(ReportRumore.java:576)
ReportRumore.processRequest(ReportRumore.java:103)
ReportRumore.doPost(ReportRumore.java:172)
javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)

root cause

net.sf.jasperreports.engine.JRException
com.aspose.words.jasperreports.AWAbstractExporter.exportReport(Unknown Source)
ReportRumore.exportReportToBytes(ReportRumore.java:200)
ReportRumore.CompileReport(ReportRumore.java:572)
ReportRumore.processRequest(ReportRumore.java:103)
ReportRumore.doPost(ReportRumore.java:172)
javax.servlet.http.HttpServlet.service(HttpServlet.java:709)
javax.servlet.http.HttpServlet.service(HttpServlet.java:802)


If you need, I can give you the code of the java servlet we use to compile and download the document.

The strange fact is that I haven’t encountered this problem before: in other reports I removed the footer band and they all worked fine

can you help me solving this problem?

EDIT: it seems that the problem manifests itself specifically when removing the subreport in the footer band, but still this happens only with this report.

EDIT2: I forgot the attachment… Here it is!

Hi Matteo,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for reporting this problem to us. Your request has been logged in our defect database. The developer, who is responsible for Aspose.Words for Jasper Reports will answer you shortly.

Best regards.

Any info about this error I’ve been having? I managed to “solved” it by leaving the footer band intact, but this is not the desired solution.

Hi Matteo,

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your request. The issue is still opened. I will ask the developer, who is responsible for Aspose.Words for Jasper Reports, take a look on this issue shortly. My apologizes for inconvenience.

Best regards,