We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error while generating Word documents

Hi people.

I am currently having 2 exceptions while trying to generate Word documents with Aspose Words. My version is Aspose Words 4.4.1

Exception

Message : Exception ‘Unexpected table parent.’ occured in Aspose.Words for .NET 4.4.1.0.
For free technical support, please post this error and the file in the Aspose.Words Forums https://forum.aspose.com/c/words/8.
StackTrace at ੓.ਗ਼.ં()
at ੓.ਗ਼.ੲ()
at ᅝ.ጱ.ጵ(ᆎ ࠀ, Boolean ጶ)
at ᅝ.ᅜ.ᅲ(ᆎ ࠀ, Boolean ᅱ)
at ᅝ.ᅜ.ᅰ(ᆎ ࠀ, Boolean ᅱ)
at ᅝ.ᅜ.ᅯ(ᆎ ࠀ)
at ᅝ.ᅜ.ᅯ(ᆎ ࠀ)
at Aspose.Words.DocumentBuilder.InsertHtml(String html)

It is suspected some chinese characters in this document might be causing issues, but we cannot confirm as we cannot step into Aspose Words itself.

A 2nd exception is this

System.NullReferenceException: Object reference not set to an instance of an object.
at փ.䋳.VisitParagraphStart(Paragraph para)
at Aspose.Words.Paragraph.Accept(DocumentVisitor visitor)
at Aspose.Words.CompositeNode.Շ(DocumentVisitor Ո)
at Aspose.Words.Body.Accept(DocumentVisitor visitor)
at Aspose.Words.CompositeNode.Շ(DocumentVisitor Ո)
at Aspose.Words.Section.Accept(DocumentVisitor visitor)
at Aspose.Words.CompositeNode.Շ(DocumentVisitor Ո)
at Aspose.Words.Document.Accept(DocumentVisitor visitor)
at Aspose.Words.Document.UpdateWordCount()

The source document for this seems pretty ordinary. I cannot detect any special characters that can cause Aspose Words to throw an exception.

Will appreciate any advice given, thanks.

Hello

Thanks for your inquiry. Could you please try using the latest version of Aspose.Words (9.4.0) and let me know how it goes on your side. If updating to the latest version does not help, could you please attach your input document here. I will check the problem on my side and provide you more information.
Please try using the latest version and the following code:

Document doc = new Document("in.doc");
doc.Save("out.pdf");

You can download the latest version from here:
https://releases.aspose.com/words/net
Best regards,

Hi Andery.

Thanks for the prompt response. I tried using version 9.0.0 but I got an license error when I tried to do that. Furthermore, I read somewhere that there are some breaking changes between Aspose 4.0.0 and and later versions, and I have to compile a certain portion of my project to try out that test. This may not be feasible for my entire solution as it is already running in Production. Are the later versions backwards compatible in this regard?

Like to ask, is there a way for me to try using the latest version without hitting into the license exception, and if there isn’t, is there a hotfix for version 4.4.1? Thanks.

Hi James,

Yes, you are right, there were a few breaking changes to the API in version 9.2/9.3 You can find full details of these changes in the migration article:
https://docs.aspose.com/words/net/aspose-words-for-net/
Also note, that every Aspose license carries one-year subscription for free upgrades to new versions released during this time. So, you can check the expiration date of your license and upgrade to the newest version. To check an expiration date of your license open the license file using notepad. You will see the following tags:
20090218
It means that you can free upgrade to version of Aspose.Words published before 02/18/2009.
Have you got any exception upon applying the license? Could you please provide me details of the exception?
Also, as a variant, you can request a 30-day Temporary License. Please refer to
https://purchase.aspose.com/temporary-license
Best regards,

Hmm my date reads 20081030.
So can I obtain the latest version of Aspose Words up to this date for testing? Thanks.

Hi

I have attached Aspose.Words 5.3.0 to this post.
Hope this helps.
Best regards,

Thanks Andrey.

I did not have a chance to test out this version yet, but if I intend to upgrade to the latest version, what will the upgrade path and pricing be like?

Hi

Thanks for your inquiry. You should ask this question in Aspose.Purchase forum. My colleagues from sales team will answer you shortly.
Best regards,