We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Error writing a Slide as SVG file

java.lang.RuntimeException: Cannot create graphic object from indexed image format

at com.aspose.slides.pa5e0ff62.pbdb106a0.p6a2feef8.ab.(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.pa5e0ff62.pbdb106a0.p6a2feef8.ab.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.axu.int(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.axu.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.axu.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.axu.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.axu.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.Slide.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.Slide.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.Slide.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.bam.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.pa5e0ff62.pa2137a2a.pa2137a2a.b.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.pa5e0ff62.pa2137a2a.pa2137a2a.c.do(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

at com.aspose.slides.Slide.writeAsSvg(Unknown Source) ~[aspose-slides-14.10.0.jar:14.10.0]

Hi Marc,

I have observed the issue shared by you and request you to please share the sample presentation with us that is throwing issue. I also suggest you to please try using Aspose.Slides for Java 14.10.0 first on your end as well. Please share, if I may help you further in this regard.

Many Thanks,

Hi Marc,

I have observed the issue shared by you and request you to please share the sample presentation with us that is throwing issue. I also suggest you to please try using Aspose.Slides for Java 14.10.0 first on your end as well. Please share, if I may help you further in this regard.

Many Thanks,

Hi,



Yes I am using release 14.10.0 (see stack trace).

Attached is the first page of the PPT, so you can reproduce the error.



Thanks,

Marc

Hi Marc,

I have used Aspose.Slides for Java 14.10.0 on my end using JDK 1.7_65 in Windows 7. I have not been able to observe issue by using sample code given in this documentation link. For your kind reference, the SVG image is attached.

Many Thanks,