We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Evaluation Copy message appears when printing

Hello,

We’re using a Developer OEM license of Aspose.Words.Net (.net 2.0) version on POS computers. Same .exe and .dll version of our code in all of them.
On some of them, a Evaluation Copy message appears when printing or when using the PrintPreviewDialog.
We checked in the logs that even tho the IsLicensed property is set to true, the Evaluation Copy message keeps being printed every time in the same computers.

Please, could you help on solving this issue?
Kind regards,

Hi Lluis,

Thanks for your inquiry. We will appreciate it if you please confirm how you are applying the license. Please make sure that you have set the license before using any other object of Aspose.Words API. Hopefully setting license properly as suggested in following documentation link will resolve the issue. However, if the issue persist then please share a sample project along with your license file via email as suggested here to replicate the issue at our end, so we will provide you more information accordingly.

We are sorry for the inconvenience.

Best Regards,

Hi Tilal,

Thanks for your quick answer.

We are using the method SetLicense with a string containing the absolute path of the license file.

Then we check the .IsLicensed property, which returns true. So we asume the license is properly setted.

Then when we print or preview the document, it has the Evaluation Copy message on it.

Best Regards,

Hi Lluis,

Thanks for your feedback. I am afraid we cannot suggest you something without replicating the issue at our end. As requested above, please share a console project along with your source documents. We will try to replicate the issue at our end and will guide you accordingly.

We are sorry for the inconvenience.

Best Regards,