Free Support Forum - aspose.com

"Evaluation Only" watermark on generated PPTX thumbnails, even though license is applied

We sometimes get a watermark on our generated PPTX thumbnails “Evaluation Only. Copyright 2004-2020 Aspose Pty Ltd”

using aspose slides V20.2

our License OrderID is 200511025946

our code that runs on load to set the License

//Instantiate the License class
Aspose.Slides.License license = new Aspose.Slides.License();
//Pass only the name of the license file embedded in the assembly
license.SetLicense(“Aspose.Slides.lic”);
//Reset the applied license
license.ResetLicense();
//Get status if license is applied or not
bool isLicensed = license.IsLicensed();
if (!isLicensed)
{
license.SetLicense(“Aspose.Slides.lic”);
}

@ivan_teage_igd_com

The stated method isLicensed() is obsolete. Please share the details of the issue in the form of sample project that you are using and stating that it is giving watermark despite using license. Please also provide the license file with us privately using message option with us. I also urge you to please try using our latest version as well with your license file before sharing with us.

Is there some other way to determine if the product is licensed? Otherwise it will be impossible to determine if our code is working correctly.

Is there a secure way to share our license file?

@ivan_teage_igd_com

The other way is to load the license file in a try-catch block. If exception is thrown on loading license, it means there is issue in loading license. If no exception is thrown, it means that license loading is successful.

You can click on my name icon in my post and then a popup will appear. Select the Message option to send the license file privately with me.

Did you fix it?
We have a same issue :frowning:

@admin_tiburon-research_ru

The issue has not been reproducible on our end. If you are persisiting with issue using Aspose.Slides for .NET 20.8 then please provide the sample project along with source file and generated output with us. For sharing the license file, please follow the guidelines below.

@admin_tiburon-research_ru

After reproducing the issue on my end, I have added a ticket with ID SLIDESNET-42179 to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.

1 Like