We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Evaluation watermark appeared on barcodes in SSRS

Hi

I have a licensed version of Aspose barcode for reporting services running on Windows Server 2008 R2 / SQL Server 2008 R2. Up until this week the barcodes were displaying fine. Now, all of a sudden the 'aspose' text is appearing in the corner of my barcodes and I am unable to remove it. Please advise ASAP.

Regards

Steve Flynn

Hi Steve,

Thank you for inquiry.

Could you please verify that a valid license file is present in the specified folders of Visual Studio and SQL Server? Or did you update anything on the server which might have caused this (although very unlikely).

Hi

As far as I am aware the license is valid. I placed the license file in the relevant directories as per the instructions and everything was working fine. Nothing has changed regarding SQL / VS but for some reason the 'aspose' text is now showing on the reports. When I preview the report in Visual Studio, the text is not there, when I deploy the report and view it through a browser, the text appears.

Thanks.

Hi,

Could you please try restarting the SQL Reporting Services and see if it works? I am sorry, but I do not have any idea how it stopped working.

Please also tell the version of the Aspose.BarCode.ReportingServices.dll present in the SQL Reporting Services\bin folder. Also zip/send the license file to me using the “Contact” --> “send saqib.razzaq an email” button on this thread. I will check in similar environment at my end.

Hi,

I have verified this behavior with Aspose.BarCode for Reporting Services 2.6. Could you please check if you have the same version.

Please use the previous version of Aspose.BarCode for Reporting Services 2.5 until this issue (ID: 30440) is resolved. Sorry for the inconvenience.

Hi

Please advise how I can find out which version I am using and how I can downgrade to version 2.5.

Thanks

Hi,

Please find the Aspose.BarCode.ReportingServices.dll in your SQL Reporting Services folder. At my end it is “C:\Program Files\Microsoft SQL Server\MSRS10_50.MSSQLSERVER\Reporting Services\ReportServer\bin”, but the path might slightly vary at your end.

Right click on dll and choose properties as displayed in the screenshot.

For downgrading, please uninstall Aspose.BarCode for Reporting Services from control panel – Add remove programs, download v2.5 and install this one.

I uninstalled Aspose via add / remove programs and reinstalled v2.5. However, this has not fixed the issue. Also, when I check the dll properties, it still displays file version 2.4.0.0

Hi,

It seems that the dll of v2.5 is not copied to the SQL Reporting Services folder. Please manually copy the dll from Aspose.BarCode installation folder\bin\sql2008r2 to the appropriate folder and then try restarting the SQL SSRS service. I hope it would solve the issue.

Thanks Saqib, this seems to have fixed the issue.

The issues you have found earlier (filed as 30440) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(2)

The issues you have found earlier (filed as BARCODREP-30440) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(2)

Hi,


With the release of Aspose.BarCode for Reporting Services v4.5.0, we have introduce a new licensing strategy. Please un-install the existing version of Aspose.BarCode for Reporting Services and install the latest one [link shared by aspose.notifier]. Use the ConfigLicense tool available in the Tools folder of Aspose.BarCode for Reporting Services installation directory to embed your license file in the machine registry.

Once you have added your license in machine registry, please restart the Reporting Services and check the deployed reports. You no longer need to place the .lic file in ReportServer/bin folder.

Note: If you are happy with your existing version of Aspose.BarCode for Reporting Services and do not care for upgrade then please ignore this notification.