We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Excel filter function does not seem to work properly

Hi,
I have an excel worksheet where I want to use the filter function to return all non-zero values from a user specified row of a table. After this I concatenate the non-zero values and give this string as a result. See cells B12 and B15 on the “calculation” worksheet of the attached excel file.
This excel file is then converted to a webform using Aspose.cells.

Unfortunately the result of the excel filter function is not evaluated correctly (it gives a #n/a value). According to the documentation however, the excel filter function should be incorporated. Could you check if you can reproduce this error?

Thanks in advance
filtertest.zip (12.7 KB)

@jurjendegroot,
We have observed this issue and logged it in our database for further investigation. You will be notified here once any update is ready for sharing.

This issue is logged as:
CELLSNET-48614 - Excel filter function does not seem to work properly

@jurjendegroot,

This is to inform you that we have fixed your issue now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.

@jurjendegroot,
Please try the latest fix
Aspose.Cells21.8.2 For .Net2_AuthenticodeSigned.Zip (5.6 MB)
Aspose.Cells21.8.2 For .Net4.0.Zip (5.6 MB)
Aspose.Cells21.8.2 For .NetStandard20.Zip (5.6 MB)

The issues you have found earlier (filed as CELLSNET-48614) have been fixed in this update. This message was posted using Bugs notification tool by simon.zhao