Free Support Forum - aspose.com

Excel Sparklines don't get saved in rendered image

We have an established system that uses Aspose Cells (ver 7.3.2.0) to open existing Excel workbooks and render specified worksheets from them to images. This has been working fine, but recently we tried to use it with some Excel 2010 worksheets that contained Sparkline objects and these fail to be reproduced in any way on the final rendered images.


Is this a known issues? Does version 7.3.2.0 support rendering Sparkline objects?

Our code is very simple and the problem is easy to reproduce:

Workbook book = new Workbook(“TheBook.xlsx”);
Worksheet sheet = book.Worksheets[0];
Aspose.Cells.Rendering.ImageOrPrintOptions imgOptions = new Aspose.Cells.Rendering.ImageOrPrintOptions();
imgOptions.ImageFormat = System.Drawing.Imaging.ImageFormat.Bmp;
Aspose.Cells.Rendering.SheetRender sr = new Aspose.Cells.Rendering.SheetRender(sheet, imgOptions);
Image image = sr.ToImage(0);

Please advise!

Regards,

Nigel

Hi,

Thanks for your posting and using Aspose.Cells.

We have found this issue. We have attached the input and output documents. Inside the input document sparklines are present but in the output document, these are absents.

We have logged this issue in our database. We will look into this issue and resolve it. Once the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-41582.

Hi,

Thanks for your posting and using Aspose.Cells for .NET.

We have fixed the issue.

Please download and try this fix: Aspose.Cells for .NET (Latest Version) and let us know your feedback.

Thanks for the prompt turn-around. I’m pleased to say that the new version seems to have solved all our Sparklines issues. Nice one…

Hi,


Good to know that your issue is resolved. We have already closed your ticket now.

Feel free to contact us any time if you need further help or have some other issue, we will be happy to assist you soon.

Thank you.

The issues you have found earlier (filed as CELLSNET-41582) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.