We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Exception when Rendering to PDF

Basically i try to replace the Standard PDF rendering from Microsoft with your product. The Report renders without error msg when the MS PDF renderer is used, but with the Aspose renderer, an exception is generated

positive number required
parameter name: bufferSize

Are there any settings to tweak the buffer size?

Hello Gottfried,

Thanks for considering Aspose.

Can you please share the source .RDL file so that we can test the scenario at our end ?

Please make sure that the report does not contain any references to external data sources. It would really be nice if you could build a sample report based over Microsoft's AdventureWorks database.

We apologize for your inconvenience.

hello

this report is very complex, its like a data driven report with about 20 subreports with all kind of different elements

do you have any clue from the error report pdf, what elements could have caused this?

or is there any way for an enhanced logfile or something i could run on the machine?

Hello Gottfried,

Sorry for replying you late.

We are trying our level best to figure out the actual reasons of this problem. Once we have some definite information, we will let you know. We are sorry for your inconvenience.

Dear Gottfried,

As I can see from exception file you've attached, exception is not

"positive number required
parameter name: bufferSize"

but

"Exception Message:
Invalid image file type: x-png"

Do you use some special images? Can you send an image or test rdl with the image of "x-png" type?

It seems that Mime-Type of image at least a little bit strange "x-png" and doesn't corresponds to standard types. We need example of image that you've used.

Also you should check out report source, may be in your report there is an embedded image with such x-png mime-type, which is not currently supported.

Something like

image/x-png

Anyway we are waiting for further information about this issue.

Thanks.