We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Export does not render table when data source is empty

If you run this report and export it to DOCX or DOC (change the datasource to anything) just make sure the datasource doesnt return data. The table is not rendered. Is this exptected ? I want to show a custom “No data available” message and need the table to remain on the page.

This seems like a bug.

Hi Neil,

Thanks for your inquiry. Aspose.Words for Reporting Services support the requested feature. You can use Tablix property NoRowsMessage to set text as “No data available”. Please read following link for your kind reference. If no record return by data source, the Table is exported to Doc/Docx with NoRowsMessage value.

How to: Set a No Data Message for a Data Region (Report Builder 3.0 and SSRS)

Hope this answer your query. Please let us know if you have any more queries.

Hi Tahir,

Thanks, i know about that setting but it removes the table. I want the table to remain displayed.

The expected result works when exporting to pdf so should work with aspose too ?

Hi Neil,

Thanks for sharing the details. I have managed to reproduce the same issue at my side. I have logged this issue as WORDSRPT-121 in our issue tracking system. I have linked this forum thread to the same issue and you will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.


Will this be included in the next release ?

Hi Neil,

Thanks for your inquiry. I like to share with you that this issue WORDSRPT-121 has been resolved. Yes, the fix will be available in next release of Aspose.Words for Reporting Services. We will inform you via this forum thread as soon as the new release is published.