Free Support Forum - aspose.com

Extra spaces/line feeds printing document to embosser printer

Hi Aspose -

We have a word document that, when sent to an embosser printer from Word, prints fine. But when sent to the same printer using Document.Print in Aspose, extra space and line feeds are produced. I could only find one other topic on this forum from 2008. I will followup and let you know what happens when the word doc is sent to a standard printer. Have you heard of this issue before and any suggestions?

Thanks - bob kells

Hi

Thanks for your request. Could you please attach the document you are getting problem with? I will investigate the problem on my side and provide you more information.

Best regards,

Hi Andrey

I'll have to get back to you on sending the document on Monday. It may contain health-related info that can't be released. One followup bit of info; Aspose can print this document correctly to a standard printer. It's just having trouble with the embosser printer.

Talk to you tomorrow - bob

Hi Bob,

Thank you for additional information. Unfortunately, I do not have embosser printer here, so I cannot test it. Have you tried using other embosser printer, maybe the problem occurs only with this particular model?

Best regards,

Hi Andrey -

We have only 1 printer as well. I have attached the template used for this form. It is a word-97 doc with mailmerge fields. I can't sent the final merged form due to health related privacy regulations. The data itself gets trimmed of all extra spaces.

bob

Hi Bob,

Thank you for additional information. But I cannot reproduce the problem on my side. Could you please try filling your template with dummy data and attach here, maybe this will help me to reproduce the problem.

Best regards,

Hi Andrey -

Attached are 3 documents.

1. "EMBOSSER CARD.DOC" - word template with mail-merge fields.

2. "Embosser document saved from WSF.doc" - final doc generated by aspose

3. "Embosser test print to file 060911.prn.txt" - prn file of final doc

The data is dummy test data.

We still have the issue of extra spaces and/or linefeeds generated at the Embosser printer when printed through aspose, but which prints fine when printed through Word.

I hope these files turn up something, but without a Embosser printer that may be difficult.

Thanks for your help.

bob

Hi Bob,

Thank you for additional information. Unfortunately, I still cannot reproduce the problem on my side. One more thing that you can try is printing your Document on a Server via the XpsPrint API as described here:

http://www.aspose.com/documentation/.net-components/aspose.words-for-.net/howto-print-a-document-on-a-server-via-the-xpsprint-api.html

Best regards,