Extraneous Fields


#1

So I am ultimately attempting to use Aspose/c++ to:

  1. Open an existing template PPTX
  2. Make a copy of the last slide.
  3. Replace the placeholder text and imagery with updated stuff.
  4. Re-export (as PPT, PPTX, PDF, etc)

Everything appears to be working fine - except that I keep getting extraneous blank “Date” and “Footer” entries added to the bottom of my slides. I get this behavior even if all I do is open and then save my PPTX template file.

auto pptPresentation = System::MakeObjectAspose::Slides::PresentationSystem::String::FromUtf8(myTemplatePath));
pptPresentation->Save(System::String::FromUtf8(workingPptFile), Aspose::Slides::Export::SaveFormat::Pptx);

Any idea how I can prevent this behavior or what I am doing wrong?

Thanks


#2

@murphke1,

Can you please share source file so that we may further investigate to help you out.


#3

QTTemplate.zip (207.9 KB)

Source file is attached.

Kevin


#4

@murphke1,

Can you please share which version you are using on your end. Also please share complete source code and generated result with us for further investigation.


#5

Complete source code is listed in the original post. I literally don’t have to do anything but open it and save it to see the problem.

  1. Open my PPT as a presentation. - auto pres = Makeobject(myfilepath);
  2. Save it as a PPTX, - pres->Save(newpath, PPTX );
  3. Open both the original PPT and the exported PPTX in Powerpoint.
  4. You’ll see that slide 2 in the exported PPTX has blank Date and Footer text boxes, while slide 2 in the original PPT does not.

Version is 19.9, grabbed from you web site last week.

Kevin


#6

Attached is another ZIP containing:

  1. Original PPT
  2. Slightly modified presentation_export.cpp from your own sample code tweaked only so that it uses my PPT as the source and exports to PPT and PPTX as well as the other formats.
  3. PPT and PPTX generated by ASPOSE

You will note that the output.ppt does not contain the extra fields, but the output.pptx does.

Thank YouPPTExportIssue.zip (755.5 KB)


#7

@murphke1

Can you please share the details of issue on your end. I have opened the saved presentation on my end and have not observe issue. Can you please share snapshot of issue.


#8

When I open “output.pptx” - the same one in the attachment above - in PowerPoint 2016 the slides looks like the attached image. Note the empty “Date” and “Footer” fields.

image.png (419.2 KB)


#9

@murphke1,

Thank you for sharing the elaboration. An issue with ID SLIDESCPP-2034 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be notified once the issue will be fixed.