File is corrupted


#1

The generated powerpoint file can be opened on my computer (using Office XP SP3), but on a colleagues (Office 2003) and using the downloaded Microsoft viewer, the message "File is corrupted" displays.

File attached.


#2

Anyone? I have also tried generating the file from 2.1.3 and 2.4.5 with similar results. If I delete the slides where the image is contained as well as the other 3 slides where the table was added using Shapes.AddTable, the 2003 corruption goes away. In XP, the file opens fine from the get-go.

I need an answer asap.


#3

The problem exists and I can reproduce it but
I didn’t find the reason of this corruption yet.


#4

i think it has to do with the truetype fonts… I’m researching more.


#5

Here's some of my findings...

I took my corrupt file and clicked "Format->Replace Fonts" and replaced any ? fonts with Arial. This fixed the problem so I thought it was my "master" slides. I replaced all ? fonts with Arial in my master slides and re-generated the presentation. The corruption came back.

So now, I replaced all fonts except Arial and regenerated. Corruption was still there. However, if I took Arial and replaced it with Times New Roman, or any other font, the corruption disappeared and the file could be opened by Office 2003. In other words, if I somehow forced PP to "rewrite" the font being used, it came out fine.

And during all of this, all the files could be opened by Office 2002 (XP) or earlier...


#6

Did you guys find anything with the fonts?


#7

That is not because of fonts. In my Office 2003 if I simply resave file then file corruption is gone out.
Looks like there is an overflow of shape identifiers but I’m not sure.
Can you send me source presentation you use to generate 2005.ppt file?


#8

Attached is the source presentation…


#9

I found the problem but we need several days to fix it.


#10

Excellent! As long as it’s days and not weeks. Thanks man.


#11

Did today’s resolve this issue?


#12

Yes, at least everything is ok now with your 2500.ppt presentation.


#13

Just downloaded the latest and created a presentation. The bug still exists. I can open fine with 2000,2002, but not 2003.


#14

Hello? What is the status of this issue?


#15

I have fixed it. The problem was with empty TextHolders.
I don’t know why but PowerPoint (and Viewer) 2003 can’t load
presentation if empty TextHolder contains description of used styles.
Hot fix will be available today.


#16

I have to tell you that I have been using Aspose.Slides (PowerPoint), Aspose.Words, and Aspose.PDF since fall of 2004 and the documentation and bugs of Aspose.Slides is much worse than other Aspose products. We have purchased an OEM license and need to get these issues resolved ASAP.

I have narrowed down the issue to Slides.AddTable:

  1. Setting the HasBullet, FontHeight, and ForeColor properties for a Portion in a table's cell does not make a difference. The master slide's text property determines these properties for the text in a table created using AddTable, except for the FIRST cell in the FIRST row in which the properties do work.
  2. Setting the TextFrame's ForeColor and FillType to Solid always makes the table fill with solid white.

Mind you, these properties work fine with a predefined table, even if you add rows using AddRow.


#17

I have to explain. I hope you understand Aspose.Slides is the only one component which is real hack of ppt format.
We have one or two development bugs per month and not more. When we investigate some new things in ppt format
we provide new features. Sometimes our guess is wrong and new feature can’t work with all presentations.

What is wrong with Aspose.Slides’s documentation? We are open for any argumented critics.

1. That is because of last hot fix which I made for you. Unfortunately you hurry me up and I didn’t have
enough time to test everything. It’s already fixed but new version is not ready yet.

2. Did you try to use it like examples and demos do? Setting new value to FillFormat.Type property reset all other properties to default value. That means ForeColor will be white after this. In all examples changing Type is the first line and changing ForeColor is the second.


#18

Thanks for the response. I am looking forward to the next release that fixes #1.

#2 is a good example of the documentation necessary to effectively use Aspose.Slides. I could not find anywhere where it says setting FilleFormat resets all other properties.


#19

#2 Yes, you are right. That’s my fault. I wrote about it in the forum but not in the docs.


#20

Found another issue (this same code was working fine in an earlier version). My method call is as follows:

Table tbl = slide.Shapes.AddTable(679, 680, 4751, 288,3, 2, 0.75, System.Drawing.Color.White);

This produces the table, but the table's length looks corrupted. I have attached the ppt.