We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

File or assembly name Aspose.Words- or one of its dependencies- was not found

Hello Alexey,
Thanks for confirming that the license is ok. Could you please let me know about the file permissions those are required for this? We have a classic asp application which actually uses the aspose components. I have tried everything till now and as a last resort I would like to check the file access permissions, thus I request you to provide some information for setting up those permissions and verification for which permissions are needed.
Vishal Kulkarni


Thanks for your inquiry. You should just have read permissions. So Aspose.Words can read the license file.
Best regards.

Hi again Alexey,
I have a folder called aspose.words in c:\inetpub\wwwroot. In this folder I have the aspose.words.dll sitting. I have other sites on the same server where they have their individual folders. In each site folder I have a folder called utils and in this utils folder I have the aspose.words.lic. Considering this, please tell me in details where and how should the permissions should be? To which user, on which file/folder I should have an access, please tell me like this. Thanks for your help. I really want to get this working as much of the tasks aree pending as aspose is not working.
Hi Alexey,
I noticed that the error number is “80070002”, its coming when I am trying to create an object of Aspose.words.license. Please let me know if you have any information on this. Thanks.
Vishal Kulkarni


Thanks for your inquiry. Web applications are run under ASPNET (IUSR) user. So you should make sure that these users have rights to read license file.
Best regards.

Hi Again Alexy,
Please let me know if aspose.words logs any errors encountered somewhere when an object created of the dll. At some times, my system is not able to create an object of aspose.words.dll and then after some days and after re-registering the dll again it starts working. I am not able to find anywhere why it stops working all of a sudden. Hence, I request you to please let me know, if aspose components anywhere log the error information or any other possible solutions to this.
Vishal Kulkarni

Hi Vishal,

Thanks for your inquiry. Maybe in your case, you should create COM wrapper. In this case, you will be able to move all code, where you use Aspose.Words into this wrapper (DLL) and use native .NET (C# or VB) to write the code.
Then you can just call methods of your wrapper to generate/process documents. Here is simple example how you can use Aspose.Words via COM wrapper. This example shows how to set font color. To achieve this follow the instructions:

  1. Open Visual Studio and create “Class Library” project.
  2. Create method, which accepts two parameters (DocumentBuilder and color name.) Here is source code of the wrapper:
using System.Drawing;
using Aspose.Words;
namespace AsposeComWrapper
    public class Methods
        public void SetFontColor(object builder, object colorCode)
            DocumentBuilder b = (DocumentBuilder)builder;
            b.Font.Color = Color.FromName(colorCode.ToString());
  1. Now, you should make your class library signed and visible for COM.
  2. After building the project, you should register the DLL using the following command:
    regasm /codebase AsposeComWrapper.dll
  3. Once your helper DLL is registered, you can use it to set color. Here is sample code:
Dim lic
Set lic = CreateObject("Aspose.Words.License")
' Open document
Dim doc
Set doc = CreateObject("Aspose.Words.Document")
' Create DocumentBuilder.
Dim builder
Set builder = CreateObject("Aspose.Words.DocumentBuilder")
builder.Document = doc
dim helper
Set helper = CreateObject("AsposeComWrapper.Methods")
helper.SetFontColor builder, "Red" 
builder.Write("Hello world!!!")
' Save output document

Hope this helps.
Best regards.

Hi again Alexey,
The probelm is back again. I get an error that “File or assembly name Aspose.Words, or one of its dependencies, was not found.”. This has happened many a times.
Earlier, it stopped working, I re-registered the aspose.words dll and it started working, but this time, inspite of registering the dll several times, I get the same error. My asp page is not able to create an object of aspose.words.
In some aspose forum, I read that some other person had the same problem. He fixed it by reinstalling the aspose components. Do you provide any installer of aspose components or you provide just the binaries? Please let me know, I would like to reinstall and test if aspose works this time.
I also have one query. In the license file, I see the expiry date as following;
Can it be a case that the aspose dll has expired and its not functioning? I had sent you the license file earlier. Please check it and let me know. I really do not know why aspose stops functioning all of a sudden. Thanks.


Thanks for your inquiry. Sure we provide MSI installer of Aspose.Words. You can download it from here:
In earlier version when you install Aspose.Words using MSI installer, Aspose.Words.dll was registered automatically. But we excluded this from MSI installer.
Now, you should register Aspose.Words.dll manually as described here:
Regarding the license, I do not this that the expired license could cause such problem. The expired license just do not allow upgrading to the versions of Aspose.Words that come out after an expiration date. But since you did not update there cannot be any problem.
Best regards.