Free Support Forum - aspose.com

First Capital Merge Field

I have inserted a merge field into a document and set the format to First Capital. I know the data is all capitals, but when I merge the document using Aspsose.Word it doesn't change the case. Title case also didn't work. I have also tried Uppercase (on a non-uppercase value) and Lowercase and those work just fine. Any ideas?

John

First Capital and Title Case change only the corresponding characters to upper case. They don’t change the rest of the characters to lower case. I believe this is what MS Word does as well.

Makes sense. I made the mistake of assuming it would change the case for all of the other letters. Thanks.

Hi Roman,

Actually, this isn’t what Word does and it’s a bit of a problem with Aspose.Words. In Word, when you choose “Title Case” it changes the entire merge field value to lower case, then upper cases the first letter of each word.

It looks like in Aspose.Words (as you previously mentioned), it does capitalize the first letter of each word, but it doesn’t start by converting to lower case. It would be really great if it worked exactly as Word does.

Thanks for considering this for a future enhancement.

Mike