We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

First slide of output ppt has a white line in the middle

Using aspose slides 14.2, but I think this occurs with 8.4 too. when I open up the source ppt as attached, all we’re doing is a simple search and replace of some text (merge fields) and then saving it back to the same format. if you take a look at the attached output file and compare to the source file, you can see there is a strange white line right in the middle of the first slide. This does not occur in all our ppt files so I assume there is something specific that aspose slides doesn’t like in the source or similar bug?

Hi Kirk,

Thanks for getting back to us. I have observed the white line appearing in saved presentation. Can you please share the sample application code with us that I may use on my end to reproduce the issue and help you further in this regard.

Many Thanks,

sorry for the delay in getting you some code. we had other priorities. I have attached some test code where you can reproduce the issue. you will need to remove some references (zywave dlls) and get latest from nuget on aspose. when you run the app, choose Aspose instead of Service, and then select the ppt file I sent you. all this does is a simple text search and replace and then inserts a logo image into the first slide. i believe its the insert image that is causing the issue. i tried a completely different ppt and that worked, so its something weird with this ppt i sent you.



fyi this is still an issue even in the version of aspose I downloaded from nuget today.

Hi Kirk,


Thanks for sharing the sample project with us. I have tried to use the sample project on my end and unfortunately there are many missing things in my environment for this entire solution that you are using on your end. I am therefore unable to use it on my end for this reason. However, I have viewed the code section where you are replacing the text and you are rightly replacing it on portion level. I request you to please try using Aspose.Slides fort .NET 14.3.0 on your end as well that we have released yesterday. If the issue is still incurring then please create a small working sample application that focuses around Aspose.Slides usage and reproducing issue on your end. I will really appreciate your quick cooperation in this regard and will be able to help you further once requested information will be shared.

Many Thanks,

the sample app I sent you is using the latest versions of all the aspose dlls. in order to get it to work just do this.

  • remove all the references to dlls that start with “zywave”
  • try to build and comment out all the lines that are in the window codebehind that cause build failures
  • run the app
  • select “Aspose” in the dropdown
  • use the … button to select the ppt file I sent and press build. the output.ppt will be in the bin directory so you can see what it looks like.

Hi Kirk,

Unfortunately, I am unable to use your project owing to many interlinked things. However, I have generated my sample project by copying the major code elements from your sample. The sample project is attached for your reference as well. I have been able to observe that even if you don’t replace the text at all and simply access and save the presentation the white line appears on slide 1. An issue with ID SLIDESNET-35354 has been created in our issue tracking system to further investigate and resolve the issue. This thread has been linked with the issue so that you may be automatically notified once the issue will be resolved.

We are sorry for your inconvenience,