We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Font 'Aharoni' does not support style 'Regular'

Hi,


I’m testing aspose.tasks and when trying to read MPP file, getting error about font.
"Font ‘Aharoni’ does not support style ‘Regular’."
Cant I igrone fonts on read?

Using .Net project.read(
Thanks,

Shimon

Hi Shimon,


Thank you for contacting Aspose support team.

It seems that you are using quite an old library as Project.Read() is no more supported by the latest library. Please test this MPP file using latest library Aspose.Tasks for .NET 9.1.0 using following code segment.

Project project = new Project(“samplempp”);<o:p></o:p>


If still the problem persists, please send us the MPP file for our testing. We will analyze it to re-produce the scenario here and provide assistance accordingly.

Hi,


I’m Using Last version: Aspose.Tasks for .NET 9.1.0.0 version.
Reading project data in ‘MPP14’ format

Project project = new Project(“f:\Backup\1.mpp”);

Same Error: {“Font ‘Aharoni’ does not support style ‘Regular’.”}

Hi Shimon,


I have tried this scenario by installing Aharoni font on my system. A project file is created with task names having Aharoni font and saving it as MPP14 format. This file is opened using latest library Aspose.Tasks for .NET 9.1.0, but no issue is observed.

Could you please share your MPP file for our testing here?

Attached sample file


Thanks.

Hi Shimon,


I have tested your file but no issue is observed. Here a complete project is attached which may be used for testing. Please give it a try and let us know the feedback.

Hi,


Still error…
Please refer to attached files…

Thanks

Hi Shimon,


We are afraid that no such issue is re-produced here. Although I tried it with and without installing “Aharoni” but no issue is observed. You also may try by installing this font (if not done already) and try this test software on some other machine as well. Please provide your feedback after performing these tests on one or two other machines.

Hi,


Its happened in 2 PCs.
Please ignore font name. Today its Aharoni, and tomorrow it will be another font.
If there is missing font, Aspose will crash.
Thanks

Hi Shimon,


Thank you for providing feedback again.

I have logged this issue under Id: TASKS-34381 in our issue tracking system for further investigation by the product team. I shall write here as soon as some feedback is received in this regard.

The issues you have found earlier (filed as TASKS-34381) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.