Free Support Forum - aspose.com

Font '?' cannot be found error

Received : 2007/08/29 00:08:08
Message : I am using a PPT template file and create an instance of it using ASPOSE.slides and then fill data into this instance and save it to a destination folder. This whole stuff is working fine in Development and staging servers but i get a runtime error "Font '?' cannot be found error" in production server . The only fonts iam using are "Arial" and "Verdana" with varying sizes in the slides. Also,no font properties are being changed in code behind file.

S/W: ASP.NET 2.0, C#.net


This message was posted using Aspose.Live 2 Forum

Dear vishwa_66,

Please see is the required fond installed on production server.

I am forwarding your question to technical team to answer it.

Could you provide PPT template file and detailed exception information with stack trace.

I have attaced the error stack trace document and also the template file which we are using.

One more thing, our production server is a secure site but dev and staging are not.

Regards,

Vishy

iam not able to attach 2 files error stack trace is as below

Font '?' cannot be found.
Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

Exception Details: System.Exception: Font '?' cannot be found.

Source Error:

An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

[Exception: Font '?' cannot be found.]
ICap.Itd.AdminTool.ITDMetrics.imgbtnGenerate_click(Object sender, ImageClickEventArgs e) +889
System.Web.UI.WebControls.ImageButton.OnClick(ImageClickEventArgs e) +105
System.Web.UI.WebControls.ImageButton.RaisePostBackEvent(String eventArgument) +115
System.Web.UI.WebControls.ImageButton.System.Web.UI.IPostBackEventHandler.RaisePostBackEvent(String eventArgument) +7
System.Web.UI.Page.RaisePostBackEvent(IPostBackEventHandler sourceControl, String eventArgument) +11
System.Web.UI.Page.RaisePostBackEvent(NameValueCollection postData) +33
System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +5102


--------------------------------------------------------------------------------
Version Information: Microsoft .NET Framework Version:2.0.50727.42; ASP.NET Version:2.0.50727.42

That is not full stack trace. At least, I don’t see Aspose.Slides there.

Let me know how to get the full stack trace. I have put try catch block in all the functions, this is all the stack trace i get at run time. Today i tried one more thing, i just created an instance of the template and saved it to the destination folder without writing any data to any of the slides. Still i get the same error :(.

The most simple will be delete try catch blocks , recompile project with debug info and run.
Most probably you will see full stack trace on the web page in case it’s not disabled.
Also you can check Exception.InnerException property.

It would be great if you can provide also source code of
ICap.Itd.AdminTool.ITDMetrics.imgbtnGenerate_click method.

I have tried compliling the project in the debug mode, but this is the stack trace i could get. Anyways i am attaching the complete code behind file.

FYI, In the front end file i have 2 dropdowns (year and quarter) and an image button. On click of the image button the PPT file is supposed to come in the pop up.

One more thing, we installed all the fonts in production server same as in other servers. Still the run time error haunts.

At first, please delete or comment all this lines from the code and run application again.
Exceptions should be visible after that.

catch (Exception objExp)
{
throw new Exception(objExp.Message);
}

How it is possible to debug application if you hide all exceptions in each method?
I’d suggest reading some articles or books about right exceptions handling.

Sorry could not check the site for few days.

PFA stack trace.let me know if you need any more information from me.

Thanks,

Vishy

It looks like you use version of Aspose.Slides which was released more than year ago.
Did you try to use latest one?

tried with new Aspose components.But still same error.

I figure it out, it may be due to cloning of slides. Can i create extra slides within the PPT template and then remove unwanted slides from PPT just before saving? i just thougt of doing this as an alternative to cloning.

Let me know if this works or not.

Please read “Removing Slides” in the programmer’s guide.
Removing slides is high speed operation and works much better than cloning.

Anyway, it would be great if you also provide stack trace with “?” font exception for the last version.