We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Font gets changed on remove of text from table cell (C# .NET)

We are processing table in PowerPoint slide using Aspose code and when we make particular table cell empty and save that file then font size of that cell increases automatically.

Initial table cell font size was 8(can be seen in file - ReportOriginal.pptx) and when we make that cell empty ("") then that cell should have same font size of 8 but it increases to 18.

Attached is the project which reproduces this issue. There is file ReportOriginal.pptx which is base file to process and has table in it with proper data. Once this file is processed then font size of cell in table is increased automatically. When project is run, 1 files is created in bin/Files folder with name starting from “Report_xx_xx_xx.pptx” in which this issue can be found.

Update your licence before running this project which can be updated in “AsposeLicence.cs” files GetLicenceString method.

BugDescription.png in attachment has pictorial description of this issue.

BugDescription.png (53.8 KB)

@sisodeB,

I have observed the image shared by you. I suspect that you are probably setting the text inside cell to ("") on TextFrame level. When you do so, all the text setting get reset as compared to what was actually used previously. In order to retain the text settings, you need to set the text on portion level of paragraph inside Text frame. You can do some thing like following in your code.

Cell.TextFrame.Paragraphs[0].Portion[0].Text="";

If there is still an issue then please provide the source presentation, working sample code and generated output for reference.

I tried option suggested by you but still it is not working. Please find attached code sample. Use your aspose.dll and licence to run it.

File will created in bin/Debug/Files folder.

Aspose_TableCell_BugReport.zip (2.9 MB)

@sisodeB,

I have worked with the sample project shared by you and have been able to observe the issue. An issue with ID SLIDESNET-41123 has been created in our issue tracking system to further investigate and resolve the issue. Meanwhile, you can set the text to " " (single space) and it will retain the properties.

Let us know when this issue is fix from Aspose side so that we can update dll and check.

@sisodeB,
Sure, we will share good news with you as soon as possible.

Hello Adnan

Any updates ?

@aaksenov,

This issue will be resolved in Aspose.Slides 19.7. We will share good news with you soon.

The issues you have found earlier (filed as SLIDESNET-41123) have been fixed in this update.