Free Support Forum - aspose.com

Font is not preserved during open/save

Hello,

Thanks for the reply. It really helped.

Now I have a new problem.
We use CMC7 font (IDAutomation.com) in template.
But in a new version this font is changed to Times New Roman (see attachments).

How can I solve this problem?

ladpc

Hi,

Thanks for your inquiry.

While using the latest version of Aspose.Words i.e. 11.10.0, I managed to reproduce this issue on my side. I have logged this issue in our bug tracking system. The issue ID is WORDSNET-7472. Your request has also been linked to this issue and you will be notified as soon as it is resolved.

Sorry for the inconvenience.

Best regards,
Hi,

Thanks for your patience.

I'm sorry to share with you that on further investigation our development team came to know that they won't be able to implement the fix of your issue. Your issue is closed with 'Won't Fix' resolution. This means the issue is actually not fixed but closed because we can not fix this. This is because the opening French double quote of "Num_1" MERGEFIELD result has "Time New Roman" font; the MERGEFORMAT works on a per-word basis while merging formats of an old and a new result and hence the first word of the new result gets "Times New Roman" font. This is Microsoft Word's behaviour and Aspose.Words just mimics it. To overcome this behaviour, we would recommend you not to use MERGEFORMAT unless it is really needed. If we can help you with anything else, please feel free to ask.

Best regards,