We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Font problems on Linux

Hi, I am using Words to convert some Word and HTML files to PDF. I have an issue where the PDF rendering in some cases is practically illegible. Running the exact same code on Windows or OS X produces a perfect document, so I figured the issue was font-related. I ran into a similar issue with PowerPoint files and Slides and addressed it via Slides “FontsLoader.loadExternalFonts” call.

Per the documentation and a couple forum postings, I first tried adding my extra fonts via creating a new FolderFontSource, appending it to the list of FontSources and doing a new call to “FontSettings.setFontsSources”. This didn’t work, so I have now tried just setting “FontSettings.setFontsFolder” directly, but I’m still having the output issues. Are there any other APIs that need to be called once the directories are set?

Hi Erich,


Thanks for your inquiry. Please make sure that you’re using latest version of Aspose.Words for Java 15.10.0 on your end. Secondly, please refer to the following articles:

How Aspose.Words Uses True Type Fonts
How to Receive Notification of Missing Fonts and Font Substitution during Rendering
How to Specify True Type Fonts Location
How to Install True Type Fonts on Linux

In case the problem still remains, please attach 1) your input Word document, 2) Font files used in it, 3) source code you’re using and 4) output PDF file showing the undesired behavior here for testing. We will investigate the issue on our end and provide you more information.

Best regards,