We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Font rendering problem

This is my first post, and I search the blogs extensively prior to submitting this question.
If it has been answered already, please feel free to direct me to the thread.

We are using the developer license to pull together a proof of concept for a client. Once the client approves of the direction we will get the full license.

We have built a tool on the following platform:
Linux RedHat
Apache 2.2.3
Aspose.slides for Java
Drupal 6
Flex 3.5

We have Admin panel that allows the user to push a PPT file and create a Drupal node, which queues it up for ASPOSE to render.

Once the file is rendered the fonts are “destroyed”. We have confirmed the required Windows fonts are installed on the box, but no success.

Please take a look at the attached image.
I am looking for help understanding what is happening to the files, and how to guarantee the fonts (Arial) do not change.

Thanks in advance

Hi David,

Thanks for your interest in Aspose.Slides.

I have observed the slide image shared by you. But, in order to reproduce the issue for further investigation on my end, I need the source presentation. Please share the source presentation and also mention which version of Aspose.Slides for Java you are using.

We are sorry for your inconvenience,

I work with David and can provide a little more information about the issue.

We are currently running version 2.1.0. I have attached a Powerpoint presentation that is exhibiting the issues. In fact, every presentation we have tried thus far has yielded the same results.

The problem seems to be occurring when the thumbnail images are generated. We really appreciate any help you can provide. Thank you.

Hi Rod,

I have observed and worked on the presentation files shared by you. I have used both Aspose.Slides for Java 2.20 and 2.1.0 in windows environment and the thumbnail generated are fine. In order to verify the thumbnail generation in Linux environment, an issue with ID 18045 has been created in our issue tracking system. This thread has also been linked with the issue, so that you may be automatically notified, once the issue is resolved.

We are sorry for your inconvenience,

Hi Mudassir,

I think you reviewed this thread a couple days ago when I reached out to you via Live Chat.
We are doing a fresh install on a new box, as test.

Can you confirm if there are any known conflicts, resource issues, or directory permissions requirements that we may need to troubleshoot on our Production Server.
If there is any information that you have that may revolve around Linux (RedHat) accessing the Windows font library, or something similar that might cause an issue like this, please let us know.

Dear David,

I have consulted with our development team. Can you please try the setting mentioned over this link. Please also try following java command line option as well.


I feel there is no specific resource issue or directory permission requirements that needed to be considered. Please try suggested solution and share your feedback with us, if the problem still persists.

Thanks and Regards,

The issues you have found earlier (filed as SLIDESJAVA-18045) have been fixed in this update.

This message was posted using Notification2Forum from Downloads module by Aspose Notifier.