Free Support Forum - aspose.com

Footnotes marker

Hi,


I have issue with attached document. Marker for first footnote isn’t extracted as special char (as other markers for footnotes in this documents are), it is extracted as run. So when I open document, work with him and save it I get two times footnote marker 1.
I manage to reproduce this issue with this test:
public void test() throws Exception {
Document doc = new Document("/evinsapir.doc");
doc.save("/AsposeFootnote.doc");
}

Can You help me, where is the problem in this document?

Thanks
Best regards

Hi Djordje,


Thanks for your inquiry. When converting ‘evinsapir.doc’ to DOC format using Aspose.Words for Java 15.4.0, I managed to observe a square box in place of footnotes number (please see attached screenshot). Please confirm if this is the issue you’re asking about?

Best regards,

Hi,

yes, I reproduce same but I solve that problem with square box, square box appears because aspose somehow see that number as symbol, can You tell me why?

And there is one more issue, if You look in text before footnotes after saving with aspose two markers for footnotes with number 1 appears, see attached screenshot. Can You help me with that?

Thanks
Best regards

Hi Djordje,


Thanks for the additional information. While using the latest version of Aspose.Words i.e. 15.4.0, I managed to reproduce this issue on my side. I have logged this issue in our bug tracking system. The ID of this issue is WORDSNET-11929. Your thread has also been linked to this issue and you will be notified as soon as it is resolved. Sorry for the inconvenience.

Best regards,

The issues you have found earlier (filed as WORDSNET-11929) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.