We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Format Issues

Please see attached files. If I open file 123.rtf and save it as 1234.rtf with Aspose the formatting gets messed up...

Hi Eric,

What version of Aspose.Words are you using? I tried opening and saving your document using Aspose.Words version 9.0 and the output appeared identical. Please try the newest verison avaliable here.

If you continue to have problems could you please post the code you are using here. Also the second bold title did appear to be indented further compared to the other titles but this was because it's style was set as Body Text Indent, while the other titles were set to Normal style. If this is causing a problem then you should change it to Normal style.

Thanks,

I am using Aspose 9.0 and have also tried 9.1. I cannot agree with your conclusion. Here, please try this... here is the RTF...

Dim SR As New System.IO.StreamReader("c:\1.txt")

Dim Mem_Stream As New System.IO.MemoryStream(myEncoder.GetBytes(SR.ReadToEnd))

Dim Aspose_Document As New Aspose.Words.Document(Mem_Stream)

Aspose_Document.Save("c:\123ABC.doc", Aspose.Words.SaveFormat.Doc)

I am also including a PDF screen shot of the difference...

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information. I managed to reproduce the problem with the document you have just attached. Your request has been linked to the appropriate issue. You will be notified as soon as it is resolved.

By the way, I cannot reproduce the problem with RTF attached in the first post. Also, if open/save your RTF in MS Word the problem disappears. It seems your RTF document was created using some third-party tool.

Best regards.

Yes, the RTF was originally created using Aspose :-)

Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for additional information, but I do not think that this RTF was produced by Aspose.Words. Aspose.Words writes generator name into RTF documents. In your RTF, I cannot find generator name.

Best regards.

The issues you have found earlier (filed as WORDSNET-3582) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.