We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com



I am using aspose pdf version 4.0. I have applied formfield checkbox to a table row content like the below:

--- Row1

Long text not fit in the page and splitted to next page




Now the problem is when data of row1 is not fit in one page, that means part of data in one page and remaining data in next page, the checkbox is positioned outside table. When the all the data in Row1 fits in page, checkbox is displayed at the start of the row data. So I tried by moving the row to in its own table and set IsBroken to false, still it's not working. Is it a defect?

How to force the table row move to next page when row data not fit in the page?



Sorry for replying you late. We are working over this query and will get back to you soon. We apologize for your inconvenience.


Thanks for your patience.

I have tested the scenario using attached XML file where Table cell contains large amount of text and Text form field is also being placed in the same table cell and as per my observations when using Aspose.Pdf for .NET 5.4.0 and also with Aspose.Pdf for .NET 6.0.0, the Form field is being displayed inside the table cell even if the contents of row can not be accommodated over single page.

For your reference, I have also attached the resultant PDF that I have generated with v6.0.0. Can you please try using the latest release version and in case you still face any problem, please feel free to contact. We apologize for your inconvenience.

I've put the checkbox formfield then the checkbox is being displayed at the begining of the text which is in second page, please see the result in the attachment. I think it should display at the begining of the text which is in first page.

<FormField FormFieldType="CheckBox" FieldName="movingExistingDealership" FieldValue="On" FormWidth="10" FormHeight="10" PositioningType="ParagraphRelative" IsReadOnly="true" ReferenceParagraphID="TextParagraph" Top="0" IsBordered="true"CheckBoxIsChecked="true"></FormField>