We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Formulas in templates give error - #REF (on upgrade from ver4.7 to ver4.8)

Hi,
We upgraded from aspose.cells version 4.7 to 4.8 and some of the existing formulas in templates are broken and give a #REF error.

For eg.

=OFFSET('Equipment Compiler'!$B$3,1,0,COUNTA('Equipment Compiler'!$B$2:$B$500)-1)

comes out as -

=OFFSET('Equipment Compiler'!$B$3,1,0,COUNTA('Equipment Compiler'!#REF!)-1)

We haven't changed anything in the conversion code, the only change is upgrading from version 4.7 to 4.8, this used to work fine in the previous version.

This is breaking a lot of our template reports, please do look into it and a quick response would be highly appreciated.

thanks,

Jaideep.

Hi Jaideep,

Please forward us any of your Template file which is causing issue. We will look into this issue thoroughly using the template and will update you with the solution as soon as possible.

Thanks,

Salman,

thanks for the response.

Please find attached a sample template file which will demonstrate this issue. If you export using this template - you will notice the formulas in cell O4,P4 etc all don't come out in the output excel file.

thanks,

Jaideep.

p.s. I have changed the extension from .xltx to .txt to attach the file, please revert it back to test2.xltx for your tests.

Hi,

I did not find the issue in it.

As the issue of saving xls file, the function IFERROR is the new feature of MS Excel 2007, MS 2003 do not support this function.


Please try our latest version. Download the latest version 5.1.3 from here.

http://www.aspose.com/community/files/51/.net-components/aspose.cells-for-.net/default.aspx