Free Support Forum - aspose.com

Generated document causes eternal running loop in updateFields function

Affected version: 15.1.0 -> 15.5.0

Affected OS: Linux, Red Hat and Ubuntu.

We have a generated document that causes eternal loops on all our servers. I have investigated the matter and noticed that the loop starts at the updateFields function. The attached document shows how the document is just before updateFields is called.

Any idea on how we can work around this rather important issue?

The issue appears to be triggerd by a large amount of hyperlinks within a table cell, i added a fix to avoid just that and the document generated just fine. Check the attached document as a example.


The right column on the last row in the first table originally had around 900 hyperlink elements.

Hi Tor,

Thanks for your inquiry. The document eternalLoop.docx does not open in MS Word 2013 at my side.

torhenning:

The issue appears to be triggerd by a large amount of hyperlinks within a table cell, i added a fix to avoid just that and the document generated just fine. Check the attached document as a example.

The right column on the last row in the first table originally had around 900 hyperlink elements.

Have you fixed the shared issue? If you are still facing the issue with Document.updatefield method, please share a runnable Java application which generates the problematic document. We will then provide you more information on this along with code.

We have added a workaround which does not trigger the issue. I will see if i can (easily) reproduce the problem.

Hi Tor,

Thanks for your feedback. Please feel free to ask if you have any question about Aspose.Words, we will be happy to help you.