Free Support Forum - aspose.com

Generating PDF from RTF document added error message on the PDF

We are using Aspose.Words file version 11.0
When we are generating PDF from the attached RTF document an error message is added to the PDF document. It was added to the beginning and to the end of the document.
Error is: "Error! Reference source not found. Error! Reference source not found"

I attached the two files, the RTF and the PDF.

Thanks,

Hi Eran,


Thanks for your inquiry. I have worked with your document and like to share with you that your document contains Ref fields. { [REF] Bookmark [Switches ] }, The REF field inserts the text or graphics represented by the specified bookmark. The bookmark must be defined in your document.

Please update the REF fields by using MS Word and press Alt + F9. You will get the message “Error! Reference source not found”. Aspose.Words try to mimics the same behavior as MS Word do. If you save your document to PDF by using MS Word, you will get the same error message in PDF file.

Hope this answers your query. Please let us know if you have any more queries.