We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Getting Error: "Input string was not in a correct format"

Have 2 PDFs - trying to use your Extract Text methods ( same as in the link below ) - they have different data in them - but are in the same format. For the first PDF - works great! was ready to test in production – BUT – the other gives me a {“Input string was not in a correct format.:”} exception with no additional data.

http://www.aspose.com/demos/.net-components/aspose.pdf/csharp/PdfDemos/Text/ExtractText.aspx

I can’t post the files here – but if someone in your support team contacts me directly, you can hopefully see what I see and see if there is a resolution.

If we can resolve this we will be purchasing a license – if not, I need to look for another product.

Please contact me at lancewlarsen@gmail.com

Hi Lance,

Thanks for your interest in our products.

Can you please share which version of Aspose.Pdf for .NET you are using ? as in latest release version of Aspose.Pdf for .NET 6.3.0, we have corrected some issues related to text extraction from PDF document. However if you still encounter the same issue with v6.3.0, please share the source PDF file so that we can test the scenario at our end. For your convenience, I have marked this forum thread as private so that no one else other than Aspose staff can access the resources shared in this thread.

Besides this, if you are still not comfortable, you may directly send us the PDF document causing this issue. In order to send the file, please follow the instructions specified over
How to send a license?

Updating from 6.2.0 to 6.3.0 worked – thanks!

Recommending strongly that we purchase a license asap. :slight_smile:

What’s the duration of the temp license again?