Getting intermittent "Table is corrupted" messages on certain configurations


#1

We've been receiving an increased rate of "table is corrupted" messages from our customers. This has popped up since we've moved from a 12/15/2005 version to the latest version.

The problem is that I'm having a tough time recreating the message. I've attached the generated document. If you notice at the very end of the document, there's an area for signatures. In this area, it looks like there's some bullets that were randomly inserted and cannot be removed.


#2

I’m also attaching the “Signature” HTML that is used to insert that erroneous part of the document…


#3

Is this issue related to: http://www.aspose.com/Community/Forums/44967/ShowPost.aspx?

Has anyone read this thread?


#4

I have opened and save the attached document using Aspose.Words 3.5.3 and it worked correctly, no error popped up. The html you have provided also appends correctly.

Please send us the code snippet sufficient to reproduce the error.


#5

You misunderstood my email. The attached document displays an error for some of my user's configurations. I have not seen the error.

Also, if you look at the document, did you notice the "floating" bullet points?

For background reference, I have been using Aspose.Word for almost 2 years now as an OEM subscriber. I have 152 posts under my belt, most of them helping you guys troubleshoot and fix the bugs found in Aspose products. www.scoreandreport.com


#6

Sorry, I've missed your point the first time.

Yes, now I see that there are bulleted paragraph after the tables. Looks that InsertHtml does not stop marking paragraphs as list members under some conditions. I have logged this problem to our defect base as Issue #954. Hope we will be able to deal with it by the time of the next release.


#7

Since this bug is occuring on our production site, I need a workaround. Should I remove "

    " elements in the above HTML?

#8

We are looking at this issue right now and we are going to release in 1-2 days so probably no workaround is needed unless this problem is too deep to be fixed immediately. We'll contrive something for you in this case.


#9

There are at least three problems you are reporting in one post. This is where it really gets confusing for the support and for yourself.

1. Extra bold formatting in imported HTML. This is now fixed, will be released in Aspose.Words 3.6 soon.

2. Extra list bullet after a table in imported HTML. This is now fixed, will be released in Aspose.Words 3.6

3. The "table is corrupted" message shown by MS Word to the users when they open a document generated by Aspose.Words. Please let us know what MS Word version do they use (including service pack if possible). If you can get a document that causes this problem (both before and after it is processed by Aspose.Words) attached to this forum, it will help. Otherwise there is no fix yet. It seems there are some rare situations where Aspose.Words produces tables that cause MS Word 2000 to crash, we are looking to obtain documents where this happens so we can investigate.


#10

One case is using Word 2000 (9.0.2720) on Windows XP Professional. For us, the critical issue is the table corruption since this error makes it impossible for users to open the document.


#11

Do you have a document that crashes MS Word 2000? The document you attached in the first forum Report_3719.doc opens in my MS Word 2000 okay withou a crash.

To solve the problem we need:

1. A document that crashes MS Word 2000

and

2. The original document from which the above document was produced.


#12

Here's a couple suspected documents. Again I can open these fine as the error message has never been duplicated by me, but some customers have reported that these docs show the message.


#13

Did any of these documents display the error message for you?


#14

Great. Anthony.doc causes MS Word 2000 to crash. If I can just get the original document before processed by Aspose.Words I’m sure we will solve the problem.


#15

I think the problem is solved. Another customer had a very similar issue. Looks like the same in your document.

In some of the tables you have a row where a first cell is specified as merged to previous cell. Apparently MS Word 2000 does not like that and crashes, whereas MS Word 2003 recovers from this.

You need to fix this in your code that generates the table (you probably build it using DocumentBuilder). You need to set CellFormat.HorizontalMerge = CellMerge.None for the first cell in each row of a table.

We are also going to add this "automatic fix" to Aspose.Words so it does not let you produce first cells merged to previous.


#16

Should “CellFormat.HorizontalMerge = CellMerge.None” be called before or after InsertCell()?


#17

When you call InsertCell a new cell is created and the cursor is placed inside it. DocumentBuilder.CellFormat at this stage is "attached" to the current cell so modifying it will modify the properties of the current cell. So it is better to specify horizontal merge after you call InsertCell.