GridDesktop Cell Format doesn't stick or change


#1

Some Cells When you right click and select format when you make changes the format doesn’t stick.
Also for some reason the same cell with show the locked check box checked even thou no cell is locked.

Using Test App
Right Click on Cell 020 select format set to Number
Check Protection locked will not be set
Click Okay
On Selection images
image.png (9.8 KB)
image.png (3.7 KB)
Okay select cell and right click select format

Now it shows custom with type: Sometime it just goes blank
image.png (7.6 KB)
And now under protection the cell is locked.
image.png (3.4 KB)

I am testing with 18.7
AposeExcelGrid_formatmenu.zip (83.0 KB)


#2

@SEMSDev,

Thanks for your query.

I have tried with one of the custom formatting in Aspose.GridDesktop as given below:
$#,##0.00_);[Red]($#,##0.00)

It works fine and always displays numbers as per the required format. I tried the sample format provided by you in Excel, but it does not have any effect.

By default, protecting a worksheet locks all cells so none of them are editable. To enable some cell editing, while leaving other cells locked, it’s possible to unlock all the cells. You can lock only specific cells and ranges before you protect the worksheet. You may first set status of cells to lock/unlock and then protect the sheet.


#3

Just to clarify. I was trying to set the given cell to a standard number format and it didn’t seem to keep the change. Also no cells should be locked I unprotected and unlocked all the cells.

.


#4

@SEMSDev

I have created an XLSX file with Button 2 on the Form in your application, then right click on a cells Format Cells option but can not find locked cell in protection tab, and can not notice changing of number format.

Please list the name of problematic cells exactly and the sequence to notice it, or you can create a video of screen to explain this issue a bit more. So that I can investigate it accordingly.


#5
  1. Open New Attached Test App.
  2. On Sheet Named Train A&B Select with the mouse cell O20
  3. Right Click the Mouse
  4. Select Format Cells from the context Menu
  5. Select the protection tab
  6. Notice do not change anything that the Locked Check box is Unchecked.
  7. Select Number Tab
  8. click on Number from the Category Field
  9. Click Okay
  10. On Sheet Named Train A&B Select with the mouse cell O20
  11. Right Click the Mouse
    12)Select Format Cells from the context Menu
  12. Select the protection tab
  13. Notice *Locked Check box is now checked (We never changed this)
  14. Select Number Tab
  15. Notice the format is not set to Number in the category field it is set to custom

AposeExcelGrid.zip (71.8 KB)


#6

@SEMSDev,

Thank you for providing detailed steps. We will analyze the problem according to these steps and provide our feedback soon.


#7

@SEMSDev,

We were able to observe the issue but we need to look into it more. We have logged the issue in our database for investigation and for a fix. Once, we will have some news for you, we will update you in this topic.

This issue has been logged as

CELLSNET-46237 - Problem with Cell Format


#8

@SEMSDev,
This is to inform you that we have fixed your issue (logged earlier as “CELLSNET-46237”) now. We will soon provide you the fixed version after performing QA and incorporating other enhancements and fixes.