We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

GridWeb OnCellSelected server event

Hi,


To update you, the problem has been fixed, hopefully, we will release the new fix in (1-2) days. You may set EnableAJAX to true, The GridWeb will work fine.

Thank you.

Hi,

Thanks for using Aspose.Cells for GridWeb.

We have fixed this issue. Please download and try the latest fix: Aspose.Cells
for GridWeb v2.7.15.2002

The issues you have found earlier (filed as CELLSNET-41385) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.

Hi,

Sorry for my late answer.

I updated the Gridweb to its latest version (2.7.16.2000) however I have a Javascript issue…

Here is the call stack :

initContent, acwmain.js, Line 68
acwmain, acwmain.js, Line 55
Global code, WebReportGeneratorView.aspx, Line 436

The error happend on root.appendChild(this.xmlDoc.createElement(“SELECT”)); because root is null. I use IE10 with a HTML5 doctype if it could help…

I cannot understand why, maybe you will help me.
Thanks,
Romain.

Hi Romain,


Please try our latest attached latest version/fix:Aspose.Cells.GridWeb.2.7.17.2001.zip
If you still find the issue, kindly create a sample project(runnable), zip it and post it here to reproduce the issue on our end. We will check it soon.

Thank you.

Hi,

I just tried with the latest version Aspose.Cells.GridWeb.2.7.17.2001.zip however I still have the issue.

I’ve attached you a sample project witch reproduces the problem. You just have to execute it on IE10.

I wait for any update from you.
Thanks

Hi,


Thanks for the sample project.

I tested your attached sample project but could not reproduce the issue/error on IE10, Google chrome etc. Could you give us more details and steps involved to reproduce the issue on our end. Also provide some screen shots to highlight the issue when running onto the browser. It will help us to look into your issue more accurately and consequently to fix it.

Thank you.

Hi Amjad,

I have recorded a short video which shows the issue.

I attach it to this post.

In fact the problem happens only on IE10. On Google chrome and Firefox, it works fine.

Thanks,

Hi,


Thanks for sharing the sample movie to demonstrate the issue.

I have tested your issue in IE 10 but still could not find the javascript error issue. Please find attached the movie taken on my system. However, I noticed one issue i.e. After loading the file into GridWeb, I cannot edit or update any cell value. Do you find this issue (" i.e. After loading the file into GridWeb, I cannot edit or update any cell value"), could you confirm this?

Thank you.

Hi,

The GridWeb seems to not be fully compatible with IE10. However I found a workaround which allows me to work during you fix the issue. Here it is :



That tag forces IE browser to interpret the document with the IE9 standards.

Regards,
Romain.

Hi,

Thanks for the quick answer,

You seem to have the same issue. Although, if you press F12 button when the page is loaded and then go Script tab and click on Start debugging button, you will see normally the same Javascript issue (showed in my sample movie).

Let me know if this is exact.
Thanks,
Romain.

Hi,


Thanks for providing further details.

I got some scripting exception in acwmain.js. I have logged in a separate ticket with an id “CELLSNET-41557”. We will look into your issue soon.

Once we have any update on it, we will let you know here.

Thank you.

Hi,

Thanks for your posting and using Aspose.Cells for GridWeb,

We could not reproduce the issue in our latest version Aspose.Cells.GridWeb.2.7.17.2002 in our IE9.



However we do not have IE10 installed. Please try IE9/chrome/firefox with our latest version.

Hi,

That is what I said, the Grid works fine on every browser except on IE10.

Please let me know when the issue will be solved.

Thanks,
Romain.

Hi,

Thanks for your posting and using Aspose.Cells for GridWeb.

We have logged your comments in our database. We will look into your issue and resolve it Once we will have some update for you, we will let you know asap.

Hi,

Well, we can add inside the page section
Thus the IE will parse the document like in IE9 document. It will fix your issue.

http://stackoverflow.com/questions/13871092/ie10-javascript-access-xml-element-issue
detail:
xmlDoc.loadXML(element.innerHTML);
in IE9 element.innerHTML :
in IE10 element.innerHTML :
thus var root = this.xmlDoc.selectSingleNode("DATA");
this will come to null

Hi,

I have another question about the new Event handler you added to your gridweb control. In fact, I created a server side function that I have associated to that Event like this:

CellEventStringHandler myhandle = new CellEventStringHandler(this.myCellClickOnAjax);

From that event I can get a CellEventArgs which contains the WebCell :

var reportCell = e.Cell;

However I noticed the only thing I can get is the old cell (previously selected). I just want to know if there is a possibility to get the new selected cell.

Thank you for your advices,
Romain

Hi,

I am sorry I made a mistake in my previous post. The cell I can get in my event is indeed the new selected cell. However, the reason why I have been misled is that the coordinates of the cell are inversed.

e.Cell.Row => column
e.Cell.Column => row

Waiting for any update from you,
Romain.

Hi,


Thanks for providing us further details.

Yes, you are right, the row and column are mismatched. We will look into the issue to figure it out soon.

Once a fix is ready, we will provide you here.

Thank you.

The issues you have found earlier (filed as CELLSNET-41592;CELLSNET-41557) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.