We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

GridWeb's data format and Chinese letter problems

Hi,
I’m using gridwebdemo 8.2.2.1.

  1. in customformat.jsp, the string in cell “B4” should display 543,123,456.789, but it is 543123456.789.
  2. when I input “中文” into a cell,but when the cell lose focus, the string in the cell changes to “中文”.
    Can anybody tell me how to make it work properly?
    Thanks!

Hi Arnold,

Thanks for your posting and using Aspose.Cells.

We were able to observe the issue of number format. When the number format is #,##0.0 then excel displays the number
543123456.789 as 543,123,456.8 but GridWeb displays it 543123456.8.

We have logged this issue in our database for investigation. We will look into it and fix this issue. Once, the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as

  • CELLSJAVA-41071 - Wrong number format in customformat.jsp

For your second issue, are you inputting the chinese character by typing from keyboard or copying-pasting it. I tried copying-pasting the characters and they showed fine in GridWeb.

Hi mshakeel.faiz,

The second issue is:
1.in IE9(or in IE11), when I typed in(or copied and pasted) the Chinese letters(“中文”), they were shown correctly; and then I clicked some other cell, they changed into “中æ”, and then I clicked the cell and the cell changed into edit mode, they changed into “中文” again. that was very strange.
2.in Chrome, it was different. when I typed in(or copied and pasted) the Chinese letters(“中文”), they were shown correctly; and then I clicked some other cell, they changed into “中æ”, and no matter how I clicked or did other things, they didn’t change back to “中文” again.
3.If the Chinese letters were set in server side(e.g gridCells.get(“B6”).putValue(“中文”);), they were properly shown. But if I tried to add some new letters, and when the cell losed focus, the text changed into strange letters again, as described in 1. and 2.


And by the way, I wrote some code like this:
GridValidation gridValidation = gridValidationCollection.Add();
gridValidation.AddACell(“C11”);
gridValidation.setOperator(OperatorType.BETWEEN);
gridValidation.setValidationType(GridValidationType.DROP_DOWN_LIST);
ArrayList C11List = new ArrayList();
C11List.add(“下拉列表选项1”);
C11List.add(“下拉列表选项2”);
C11List.add(“下拉列表选项3”);
gridValidation.setValueList(C11List);
And when I selected an option(e.g “下拉列表选项2”), and I clicked some other cell, the text changed into strange letters too. I think it is the same issue as typing in(or coping-and-pasting) Chinese letters into a cell.

My OS is Windows 7, Simplified Chinese version, maybe it is different from the one you used to test, I think.

I hope what I found be of any help to you, thanks again.

Hi Arnold,

Thanks for your feedback and using Aspose.Cells.

Please also provide us screenshots highlighting the issues with red circles so that we could add this issue as a separate ticket in our database for investigation and a fix.

You can provide a Word document containing your screenshots and the steps you took to replicate this issue and attach with your post.

Thanks for your cooperation.

Hi mshakeel.faiz,

I attached a word document, if you have any further questions, please let me know.

Hi,


Please try our latest version/fix: Aspose.Cells.GridWeb v8.2.2.2 for JAVA

We have fixed your issue now.

Let us know your feedback.

Thank you.

Hi Amjad Sahi,

I tried with v8.2.2.2 for Java, and it worked! Thanks!

Hi,


Thanks for your feedback.

Good to know that your issue is resolved now. Feel free to contact us any time if you need further help or have some other issue or queries, we will be happy to assist you soon.

Thank you.

The issues you have found earlier (filed as CELLSJAVA-41071) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.