We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

HELP! Aspose.Words stop working

We've been using Aspose.Words 4.2.6 and recently upgraded to the latest one 5.2.2

Then we got the error:

error '8000ffff'

/_server_common/hirediversity/resume/alter/save.asp, line 87

The line 87:

Set license = CreateObject("Aspose.Words.License")

Here is our environment;

  • Win 2003 server IIS 6
  • Classic ASP
  • Aspose.Words.dll is D:\ActiveWebs\HireDiversity\Aspose\Aspose.Words\Bin\net1.1, and the license file is there too.
  • The asp page which creates the Aspose.Words.License is D:\ActiveWebs\HireDiversity\_server_common\hirediversity\resume\alter\save.asp

We tried to install various versions: 5.1.0, 5.2.0…

And tried to register it manually using the command below;

Regasm "D:\ActiveWebs\HireDiversity\Aspose\Aspose.Words\Bin\net1.1\Aspose.Words.dll " /codebase

The funny thing is whenever I uninstalled and reinstall different version or unregister and register using regasm, Aspose.Words works for 10 – 20 minutes.

After 10 – 20 minutes, it fails showing the same error message.

We check the permissions of folders and files, they seem OK.

Why do you think it works for some minutes and stops working?

I really need some help on this.

Thank you.

Hi

Thanks for your request. I made a research and found this problem could be caused by IE7 security upgrades. Here is the problem description.

http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=294241

You can try workarounds suggested here:

http://connect.microsoft.com/VisualStudio/feedback/Workaround.aspx?FeedbackID=294241

Also you can try removing IE7 or removing KB937143 upgrade:

- Go to add remove programs.

- Check the "Show updates" box at the top

- Scroll down to Internet Explorer 7

- Find and select KB937143

- Click "Remove" (You may get a warning - ignore it)

- Restart the server.

Also I found that the same problem could be caused by KB944533 upgrade.

Please let me know if this helps.

Best regards.

Thank you for the research.

I checked the server, but no KB937143 nor KB944533 installed.

So our problem is something different from the one discribed in the links you gave me.

Although I tried,

"Give Everyone Read access to HKEY_USERS\S-1-5-20\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones"

and Aspose started working again.

But usually whenever I tried something, like uninstall & reinstall / manually register.., it works for a while and stops working.

So I will watch how it goes and keep you posted.

I really hope this solves the problem!

Hi

I also tried to install Win2003 server on my side, installed IE7 and the latest upgrades. But still can’t reproduce the issue. Maybe problem was resolved in the latest upgrade.

Try installing KB953838 and KB938127 upgrades. Maybe this could help.

Best regards.

Hi Alexey,

Our Aspose.Word seems working fine since I gave Everyone read access to HKEY_USERS\S-1-5-20\Software\Microsoft\Windowns\CurrentVersion\Internet Settings|Zone.

Thanks for all your help!