Help error tracking in aspose


#1

Dear aspose.powerpoint team.
I have a powerpoint which is really nothing out of the ordinary.
I have tried to open it as a presentation object passing a filestream but when ever i try I get the errormessage below:
This seems to an error in the aspose dll. we are using version 1.5.12.0, a licensed dll, could you track it further? I have attached the presentation.

By the way I have tried plenty of other presentations which doesen’t give me this error, I just can’t see why this one does.

Error tekst:

System.NullReferenceException: Object reference not set to an instance of an object.

at Aspose.PowerPoint.Presentation…ctor(t fs)

at Aspose.PowerPoint.Presentation…ctor(Stream stream)

at NycomedControlLibrary.Ppt2Pdf.Convert2PDF() in D:\Visual Studio Projects\nycomed.com\NycomedControlLibrary\Ppt2Pdf.vb:line 90"


With regards
Morten


#2

Dear Morten,

The problem is url with bookmark on 19th slide.

It looks like MS PowerPoint store it separately in 2 different unicode strings.
I added support for that. Hot fix will be published on Monday morning.


#3

problem solved!
Thank you.

/Morten