Free Support Forum - aspose.com

Hidden sheets showing in v8.5.1

Hi,

We have some web reports based on Excel templates in which some sheets are set as hidden. Previously it used to work with some previous version (I am not hundred per cent sure whether it was working with v8.2 which was our most recent installation or not) but it does not seem to work with v8.5. Is this something you are aware of?

Thanks,
Behzad Samadianpour

Hi Behzad,


I am not entirely sure of your presented scenario however, it seems you are using Aspose.Cells.GridWeb control. Could you please confirm this? Moreover, please provide a demo application along with input spreadsheet for thorough investigation in this regard.

Thank you for your understanding & cooperation.

Hi Babar,



Thanks for your response to my query.



Attached please find a copy of the relevant part of the code where I create HTML/PDF reports out of some Excel templates. I am not use=ing Aspose.Cells.GridWeb control, I am actually using an asp.net web form.The web form requests the processing of the report from a Windows WCF service which calaculates the formulae(both custom and Excel) and saves the workbook as HTML/PDF. The HTML page is then picked up by the web form and dosplayed. I have also included the report which contains a hidden sheet(Parameters). I think it is losing the hidden property when saved as HTML.



Please let me know if you need more clarification.



Regards,

Behzad Samadianpour

Hi,


I have evaluated your issue a bit. I noticed the issue as you mentioned by simply converting your template file to HTML, by default, the Parameters worksheet (hidden) is displayed in the browser when opening the output HTML file into it. Please use HtmlSaveOptions.ExportHiddenWorksheet attribute to set it to false in your code, see the following sample code for your reference:
e.g
Sample code:

Aspose.Cells.Workbook book = new Aspose.Cells.Workbook(“e:\test2\New Dashboard.xltm”);
HtmlSaveOptions options = new HtmlSaveOptions();
options.ExportHiddenWorksheet = false;
book.Save(“e:\test2\out1.html”, options);

I have tested using the attribute to set it to false and it works fine.

Hope, this helps a bit.

Thank you.

Hi Amjad,

Thanks for the instructions. I have made the relevant change and it works fine.

Regards,
Behzad Samadianpour

Hi,


Thanks for your feedback.

Good to know that your issue is sorted out by using the suggested attribute. Feel free to contact us any time if you need further help or have some other issue or queries, we will be happy to assist you soon.

Thank you.