We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

How to set Hyphenation on the document?

Hi,
I’m attempting to merge two documents together.
The problem is that document A has the “automatically hyphenate document” setting to false.
Document B has it set to true.
(This is found in word 2003 under Tools->Language->Hyphenation)

So the resulting document picks up on the settings from document A, so the automatic hypenation is off. The resulting document doesn’t look correct.

Is this possible to do? where is this setting in aspose words? I can’t seem to find it. Can only find it per paragraph.

Thanks.



Hi

<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thanks for your inquiry. Currently, there is no way to set “Auto Hyphenation” option using Aspose.Words. I created new issue #8803 in our defect database regarding this problem. I will notify you as soon as it is fixed.

As a workaround, you can create empty document where hyphenation is enabled and append all documents to this document.

Best regards.

Hi there

I know it’s been a while, but right now I have exactly the same problem.

Has anything changed in the last 4 years or is there still no way to set “Auto Hyphenation” option using Aspose.Words?

Regards

Hi Christian,

Thanks for your request. Unfortunately, currently there is no public API to access/set these 'Auto Hyphenation' options. We will consider providing such API in one of future version of Aspose.Words. We apologize for your inconvenience.
Best regards,

The issues you have found earlier (filed as WORDSNET-2338) have been fixed in this .NET update and this Java update.


This message was posted using Notification2Forum from Downloads module by aspose.notifier.
(7)