We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Hyperlink problems when converting doc to PDF

Hello,

We are using the Aspose.Pdf.dll version 7.0.0 to convert doc to pdf.

When the attached doc is converted to pdf the hyperlinks are not always converted correctly. In the doc the hyperlinks are correct but in the pdf, characters in the hyperlinks get swapped with other characters.

If the hyperlink consists of multiple words, the hyperlink can be incorrect for one word of the hyperlink but not others.

It’s not consistent - each time the doc is converted, it’s different hyperlinks in the pdf that incorrect. And it’s not just this doc. It’s happening for other docs as well.

In the attach pdf, you can see this in the following items:

Item 8 : hyperlink: Book 345 at Page 429

If you hover over at you get:
http://eweb.com/DownloadDocument.aspx?DocumentID=60720 (BAD)

If you hover over any other part of the hyperlink you get:
http://eweb.com/DownloadDocument.aspx?DocumentID=60720 (GOOD)

Item 8 : hyperlink: Book 348 at Page 267

If you hover over 348 you get:
https://orders.cltontheweb.com/DownloadDocument.aspx?Docu**j** entID=60721 (BAD)

If you hover over any other part of the hyperlink you get:
https://orders.cltontheweb.com/DownloadDocument.aspx?Docu**m** entID=60721 (GOOD)

Item 16 : hyperlink: 1002812

If you hover over this hyperlink you get:
[https://orders.clsontheweb.com/DownloadDocument.aspx?DocumentID=60713 (BAD)

But you should get:
http://ontheweb.com/DownloadDocument.aspx?DocumentID=60713 (GOOD)

Thank you,
Kris Dichtl

Hi Steve,

Thanks for using our products.

Adeptive:

We are using the Aspose.Pdf.dll version 7.0.0 to convert doc to pdf.

Can you please share sample source code you are using with us. This will help us to figure out the exact issue and reply back to you soon.

We apologize for your inconvenience.

Thanks & Regards,

Yes, of course, sorry. And it turns out we are using the Aspose.Words.dll for .NET version 11.3.0 to convert the doc to pdf. My bad. I just downloaded and tried version 11.4.0, and it does the same thing - randomly swap out characters in the URL of the hyperlinks.

Document document = new Document(fileNameDoc);
document.Save(fileNamePdf, SaveFormat.Pdf);


Hi Steve,

Thanks for sharing the details. As your current request is related to Aspose.Words, I am moving your request in Aspose.Words forum. My colleagues from Aspose.Words component team will answer you shortly.

We apologize for your inconvenience.

Thanks & Regards,

Hi Steve,

Thanks for your inquiry. I have investigated the issue at my end, but I am unable to reproduce the same issue. You can check the attached output file and refer to the code below for your reference.

LoadOptions lOption = new LoadOptions();

lOption.LoadFormat = LoadFormat.Docx;

lOption.Encoding = UTF8Encoding.UTF8;

Aspose.Words.Document doc = new Aspose.Words.Document(inputFile, lOption);

doc.Save(outputFile, SaveFormat.Pdf);

In order to further investigate the issue, can you please share the sample project, so that we can create the same environment to reproduce the error.

Thank you for your co-operation.

Best Regards,

Amir Ghias

Hi Steve,


Thanks for your inquiry and sorry for the delayed response. With Aspose.Words v11.4.0, I was unable to reproduce this issue on my side either. I would suggest you please upgrade to the latest version of Aspose.Words for .NET i.e. 11.4.0. You can download it from the following link.
http://www.aspose.com/community/files/51/.net-components/aspose.words-for-.net/default.aspx

I hope, this will help.

Best Regards,

It turns out the problem is with Aspose.Pdf.dll’s PdfFileSecurity.SetPrivilege(…) method.

See attached for sample code and a sample input PDF.

Aspose, have you had a chance to look at this?

Hi Steve,


Thanks for your inquiry and sorry for the delayed response. I feel your problem is related to Aspose.Pdf, I will move your request in Aspose.Pdf forum. My colleagues from Aspose.Pdf component team will answer you shortly.

Best Regards,

Hi Steve,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

<o:p> </o:p>

Thank
you for the sample application and template file.<o:p></o:p>

<o:p> </o:p>

I
tested your issue with the latest version of Aspose.Pdf
for .NET v7.2
and I am able to notice the issue in the hyperlink “768881” (rest of the hyperlinks are fine). I have
registered your issue in our issue tracking system with issue id: PDFNEWNET-34103. You will be notified
via this forum thread regarding any updates against this issue.<o:p></o:p>

<o:p> </o:p>

Sorry
for the inconvenience,<o:p></o:p>

Great! I’m glad you’re able to reproduce it. FYI, the behavior seems non-deterministic. If you run the code for the same document multiple times, sometimes the hyperlinks that get outputted are OK, other times the same hyperlinks are bad.

Hi Steve,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Thank you for the feedback.

I have shared this information with the development team and hopefully this information will help us identify the cause of the issue soon.

Sorry for the inconvenience,

Greetings,

I’m just following up to see if any progress has been made in regards to this issue.

Thank you.

Hi Steve,


Thanks for your patience.

<span style=“font-size:10.0pt;font-family:“Tahoma”,“sans-serif”;
mso-fareast-font-family:PMingLiU;mso-ansi-language:EN-US;mso-fareast-language:
ZH-TW;mso-bidi-language:AR-SA”>Our development team is working hard to get this
issue fixed but I am afraid it’s not yet completely resolved. Nevertheless, I
have requested the team to share the ETA regarding its resolution. Soon you
will be updated with the status of correction. We apologize for your
inconvenience.



Your patience and comprehension is greatly appreciated in this regard.

I know you probably don’t want to hear this but we just noticed once that when a doc containing hyperlinks, that are the standard blue in color, was converted to pdf, all the hyperlinks were black instead. I have the converted pdf with black hyperlinks in case you need it but we have not been able to reproduce it.


Kris Dichtl

Hi Kris,<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" />

Please share your template word document and resultant PDF file with us to help us reproduce the issue at our end. This will help us figure out the issue soon.

Sorry for the inconvenience,

Hi Steve,


Thanks for your patience.

I have further discussed with development team and as per our current estimates, we plan to get PDFNEWNET-34103 resolved by the mid of September-2012. However its still not a promise. We will try our level best to get this issue resolved by the said time.

I would again request you to please be patient and spare us little time.

The issues you have found earlier (filed as PDFNEWNET-34103) have been fixed in Aspose.Pdf for .NET 9.2.0.

The blog post for this release is created over this link


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.