Hyphenation seems not to work anymore

Hi,

we are using Aspose.Words 14.5

We got a .doc that caused an error when it was printed.

I tried printing with Aspose.Words 15.3 which worked fine, but hyphenation is not working anymore.

Do you have any suggestions?

Kind regards,

Lutz

Hi Lutz,


Thanks for your inquiry. You need to
register a hyphenation dictionaries for a specified languages before
rendering to Pdf/printing. Please refer to the following article:
http://www.aspose.com/docs/display/wordsnet/How+to+Hyphenate+Words+of+Specified+Languages

I hope, this helps. If you still face problem, please share your input document along with hyphenation dictionary.

Hi Tahir,

thanks for your fast response.

I attached two files for you.

I created one with Aspose.Words 14.5 and the other with 15.3, but with the same source code.

As you can see, in the second one there is no hyphenation, and the leading between the rows in increased.

I attached all of our dictionaries and the source file as well, but I am using de-CH.dic

If you have any questions, please don't hesitate to contact me.

Thanks in advance and kind regards,

Lutz

Hi Lutz,


Thanks for sharing the detail. I have tested the scenario using latest version of Aspose.Words for .NET 15.3.0 and have not found the hyphenation issue in output Pdf. Please check attached output pdf.

Could you please point what is the issue with this output? Please also share the expected output Pdf here for our reference.