We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

IFERROR Issue with Aspose Cells when opening Workbook

Aspose Cells 7.7.2.0 has an issue when opening a workbook in relation to function IFERROR. Only occurs if workbook is .xlsb.



If a cell has a formula such as =IFERROR(A1, 0), and the referenced cell A1 is #DIV/0! then after Aspose opens the Workbook that cell’s formula becomes =A10.



See attached workbook and solution/code.

Hi Michael,

Thanks for your posting and using Aspose.Cells.

We were able to observe this issue with the latest version: Aspose.Cells for .NET 8.0.0. The issue does not occur if the file is xlsx however it does occur if the workbook is in xlsb format.

We have logged this issue in our database for investigation. We will look into it and fix this issue. Once, the issue is resolved or we have some other update for you, we will let you know asap.

This issue has been logged as CELLSNET-42530.

Hi Michael,

Thanks for using Aspose.Cells.

Please download and try the fix: Aspose.Cells for .NET v8.0.0.2 and let us know your feedback.

Thanks Skakeel.

Could you send me the NET3.5 dll please.

I can’t compile my app with this version. Suspect it is the Client Profile version.

Thanks,

Mike

Hi Michael,

Thanks for using Aspose.Cells.

Sure, I have forwarded your request to provide you .NET 3.5 dll. Once, it is available for you, we will let you know asap.

Hi,


Please try our latest fix Aspose.Cells for .NET v8.0.0.3 for .Net Client profile version (attached) for your needs.<o:p></o:p>


thank you.

The issues you have found earlier (filed as CELLSNET-42530) have been fixed in this update.


This message was posted using Notification2Forum from Downloads module by Aspose Notifier.