We're sorry Aspose doesn't work properply without JavaScript enabled.

Free Support Forum - aspose.com

Image or WordArt in header not converting correctly to PDF

we’re evaluating the software as a possibility to replace our interop methods for documents. I downloaded a temporary license and we’ve been testing it on a number of documents that we’ve had over the years.

Most are converting well, but we have one document where the header graphic or wordart isn’t converting correctly. Both printing the document with Microsoft’s print to PDF printer and the interop with MS Word 2016 safe as pdf are working correctly, but our version of Words.Net displays some wrong characters on the graphic. Is this an issue, or could this possibly be a settings problem?

SAF-Injury for Aspose.docx (31.0 KB)
SAF-Injury for Aspose.pdf (40.8 KB)

@steve.assurx

We have tested the scenario and managed to reproduce the same issue at our side. For the sake of correction, we have logged this problem in our issue tracking system as WORDSNET-22680. You will be notified via this forum thread once this issue is resolved.

We apologize for your inconvenience.

To give you some additional information, this header image is a bit unusual. It is an (.emf) enhance metafile that looks like it was edited. The strange thing is, printing the file from Apose document object to Microsoft Print to PDF, doesn’t have the problem (nor does a direct print to PDF), but since that is a more time-consuming method (considerably), we’d rather not use that method. Also, it does require the printer driver to be installed.

Every other method we have tried has converted the image correctly, including a trial version from a competitor of Aspose out of China.

After some additional searching, It would be nice if this was resolved, but for anyone else having this problem, the “workaround” mentioned in this topic worked great for us:

@steve.assurx

It is nice to hear from you that you have found the workaround of your issue. We have logged the additional information shared by you in our issue tracking system. We will inform you via this forum thread once this issue is resolved.